Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

cmquerycl: Unable to connect to server 10.101.0.146 on port 113

SOLVED
Go to solution
tommy_28
Frequent Advisor

cmquerycl: Unable to connect to server 10.101.0.146 on port 113

Hello,

I'm using mcsg 11.16.01 for ia64 suse linux.
When I run #cmquerycl -n , I got below error:
cmquerycl -n rx2600-4

Warning: Unable to determine local domain name for rx2600-4
Error: Unable to connect to node rx2600-4: Permission denied
Failed to gather configuration information.

I checked /var/log/messages, it says:
Aug 14 20:52:19 rx2600-4 cmclconfd[23750]: Unable to stat /opt/cmcluster/conf/cmclconfig, No such file or directory
Aug 14 20:52:19 rx2600-4 cmclconfd[23750]: Unable to connect to server 10.101.0.146 on port 113 (Connection refused).
Aug 14 20:52:19 rx2600-4 cmclconfd[23750]: Unable to properly gather the remote user for fd 3. Please make sure the remote node is running identd.

my ~/.rhosts
rx2600-4 root
rx1600-4 root
10.101.0.146 root
10.101.0.148 root
zx2100-2.test root
zx2100-2 root
10.101.0.211 root

my /etc/cmcluster/cmclnodelist
& /opt/cmcluster/conf/cmclnodelist

rx1600-4 root
rx2600-4 root
+

my /etc/hosts
rx2600-4:/etc/xinetd.d # cat /etc/hosts
#
# hosts This file describes a number of hostname-to-address
# mappings for the TCP/IP subsystem. It is mostly
# used at boot time, when no name servers are running.
# On small systems, this file can be used instead of a
# "named" name server.
# Syntax:
#
# IP-Address Full-Qualified-Hostname Short-Hostname
#

127.0.0.1 localhost

# special IPv6 addresses
::1 localhost ipv6-localhost ipv6-loopback

fe00::0 ipv6-localnet

ff00::0 ipv6-mcastprefix
ff02::1 ipv6-allnodes
ff02::2 ipv6-allrouters
ff02::3 ipv6-allhosts
127.0.0.2 linux.site linux
10.101.0.146 rx1600-4
10.101.0.148 rx2600-4

It is interesting I can run cmquerycl from another server:
# cmquerycl -n rx2600-4

Warning: Unable to determine local domain name for rx56702

Node Names: rx2600-4

Bridged networks (local node information only - full probing was not performed):

IP subnets:

IPv4:

10.0.0.0 eth0 (rx2600-4)

22.0.0.0 eth1 (rx2600-4)

IPv6:

Possible Heartbeat IPs:

10.0.0.0 10.101.0.148 (rx2600-4)

22.0.0.0 22.22.22.1 (rx2600-4)

at this time only 'Aug 14 21:01:36 rx2600-4 cmclconfd[24116]: Unable to stat /opt/cmcluster/conf/cmclconfig, No such file or directory ' displayed in log.
I don't find any app listening on 113 port.

Any ideas?

Thx.
5 REPLIES
Alex Lavrov.
Honored Contributor

Re: cmquerycl: Unable to connect to server 10.101.0.146 on port 113

Do you want your cluster to run with identd? Because, identd is the one who listend on the port 113. If you want just to disable it, make sure that you run cmcld with "-c" option, it works this way on HPUx, so I assume it does on linux.

Also, check if you have files "cmclnodes" in cluster directory and that all the nodes are written there.

Alex.
I don't give a damn for a man that can only spell a word one way. (M. Twain)
Liz_30
Occasional Visitor

Re: cmquerycl: Unable to connect to server 10.101.0.146 on port 113

Forgive me if I missed it but did you put the nodes into /etc/cmclnodelist?
tommy_28
Frequent Advisor

Re: cmquerycl: Unable to connect to server 10.101.0.146 on port 113

....

identd is a service that I need to start by my self. I don't see such step in Service Guard config guide.

So, the solution is simply: start identd service in /etc/init.d.

Thx for help.
Serviceguard for Linux
Honored Contributor
Solution

Re: cmquerycl: Unable to connect to server 10.101.0.146 on port 113

Make sure that identd is set to start automatically.
Alex Lavrov.
Honored Contributor

Re: cmquerycl: Unable to connect to server 10.101.0.146 on port 113

WEll, as I said, if you start cmcld with "-c" option, that it does not need identd.
I don't give a damn for a man that can only spell a word one way. (M. Twain)