cancel
Showing results for 
Search instead for 
Did you mean: 

fail to cmquerycl

SOLVED
Go to solution
Ricardo Rocha
Valued Contributor

fail to cmquerycl

Hi

I'm having problems in configuring a ServiceGuard cluster with RH EL3. When running cmquerycl i get:
Begin checking the nodes...
Looking for other clusters ... Done
Error: Node ermesinde40 is refusing Serviceguard communication.
Please make sure that the proper security access is configured on node
ermesinde40 through either file-based access (pre-A.11.16 version) or role-based
access (version A.11.16 or higher) and/or that the host name lookup
on node ermesinde40 resolves the IP address correctly.
Failed to gather configuration information.

DNS is ok, and both nodes are in /etc/hosts.
I've also configured cmclnodelist and /root/.rhosts files.

If I run this command with only the local node, it ends ok. It fails to gather the information on the other side.

I'm running out of ideas...surely someone has other ones.

Thanks,

Ricardo
"there is this old man who spent so much of his life sleeping that he is able to keep awake for the rest of his years"
7 REPLIES
Steven E. Protter
Exalted Contributor

Re: fail to cmquerycl

Shalom Ricardo,

Serviceguard has a cmnodelist file in /etc/cmcluster that supersedes and works better than .rhosts.

I suggest you look into that and test the connectivity with rlogin if you wish to continue using rhosts.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Ricardo Rocha
Valued Contributor

Re: fail to cmquerycl

Thanks for the quick reply...

I've removed .rhosts file and I'm currently working with cmclnodelist. The sytax I'm using is:
nodeA root
nodeB root

But the problem remains...
"there is this old man who spent so much of his life sleeping that he is able to keep awake for the rest of his years"
Jeff_Traigle
Honored Contributor

Re: fail to cmquerycl

Glancing through the cmquerycl man page on HP-UX, I notice the -n option requires the node_name must match the node name returned by the hostname command. Maybe you have a mismatch there that's causing a problem even though your DNS and /etc/hosts is ok... maybe...

Also might be worth checking the permissions on cmclnodelist. Ours are set up as 640. Can't recall if SG cares about this, but I know some other security-conscious applications will misbehave if permissions aren't tight enough.
--
Jeff Traigle
melvyn burnard
Honored Contributor

Re: fail to cmquerycl

which version of Serviceguard are you using?
Also, what hostnames are set for each lan on both nodes?
and finally list the contents of your cmclnodelist file on both servers
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!
Ricardo Rocha
Valued Contributor

Re: fail to cmquerycl

Hello all
Thanks for your help.
My two nodes are called "ermesinde39" and "ermesinde40" (output from hostname command).
The contents of /usr/local/cmcluster/conf/cmclnodelist are:
ermesinde39 root
ermesinde40 root
The file has 640 permissions and owned by root.
The /etc/hosts have both FQDN and hostname.
The ServiceGuard is serviceguard-A.11.16.04-0 for RedHat EL3.

Almost starting to pull my hair out!

Thanks,

Ricardo
"there is this old man who spent so much of his life sleeping that he is able to keep awake for the rest of his years"
Serviceguard for Linux
Honored Contributor
Solution

Re: fail to cmquerycl

Common causes:

# Sometimes this means that the firewall is set up incorrectly. Try turning off the firewall (at least temporarily).

# Also, identd may not have started. "identd" is the service associated with pidentd (see #2). Make sure this is set to start automatically. (I thinnk this is currently most common.

# Check that the file cmclnodelist has been created and is set up correctly. (For test purposes try "+ +"

Double check that you can ssh both ways.

Reboot both nodes.

Ricardo Rocha
Valued Contributor

Re: fail to cmquerycl

Bingo!!!
Damm firewall! Enabling the connection between the nodes solved it.
Thank you all!

Ricardo
"there is this old man who spent so much of his life sleeping that he is able to keep awake for the rest of his years"