Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

network card link status issues

SOLVED
Go to solution
Erick Arturo Perez
Frequent Advisor

network card link status issues

Hi,
I wonder if the behavior i have is an issue with the c3000 blade switch, the RedHat configuration or something on the SG configuration.

I have a two node cluster in SG (Redhat 5), each node is on a Bl460c blade and the blade is loaded on a C3000 chasis. The networking is provided by the standard HP switching present on the C3000 starter kit.

Everytime the network status in one node changes, the other node "sees" the changes.
Example: if i stop networking on node1 then on node2 you can see entries in /var/log/messages about link status changes for eth0,eth1,eth2,eth3.

if you start networking on node1 then again you will read about link status changed on node2.

I remember I read something about disabling link status reporting on the C3000 switches but i have not found that article again.

My theory is that this particular configuration (sg,c3000,virtual switch) is present, then the link status of the physical port changes according to what is being done by the underlying OS (ifdown ethX, ifup ethX). However this "link status" is propagated to all virtual ports being addressed to that physical port so each blade will "see" a link status change and SG will "think" there has been a massive network failure.

I have Windows machines running directly on other blades on the same chassis but have not seen the same behavior. Maybe Windows is not so sensitive as Linux is.

is this normal in configurations with C3000 switches or do i need to do something additional so the "status" of the link is not shared among nodes/virtual nodes?

i am actually not sure if this has to be psoted in SG or C3000 forums, so i post here first.

thanks,
2 REPLIES
Serviceguard for Linux
Honored Contributor
Solution

Re: network card link status issues

I would recommend posting this to the C3000 and Linux forums. Posting to multiple forums is OK as long as you indicate that is what you are doing.

I could not tell if the replicated status is seen only be SG or by the OS as well.
If it is seen by the OS, then it does not sound like an SG problem. If it is not seen by the OS then a useful piece of information is that SG uses MII in monitoring the network.
Erick Arturo Perez
Frequent Advisor

Re: network card link status issues

MII....hmmm interesting.
Will do some checks and repost to C3000 forum. Many thanks for the advice!