cancel
Showing results for 
Search instead for 
Did you mean: 

pidentd need package

 
mas1
Advisor

pidentd need package

Hi
I want install serviceguard on Dl380g4 and with SUSE enterprise 10.
I need pidentd package for this install and i do not have this package.
Please help
thanks , Regard
11 REPLIES
Matti_Kurkela
Honored Contributor

Re: pidentd need package

The pidentd package is available on the ServiceGuard installation media.

The Release Notes document of your ServiceGuard version has a detailed installation procedure. Please read it.

MK
MK
skt_skt
Honored Contributor

Re: pidentd need package

which version r u looking for ?
Serviceguard for Linux
Honored Contributor

Re: pidentd need package

Pidentd is not needed for SLES10.

Please recheck the docs.
Serviceguard for Linux
Honored Contributor

Re: pidentd need package

I should clarify. The version of pidentd that is part of the SLES10 distribution is used.

What I meant was there was no special version delivered by HP for this.

Sorry for the confusion
mas1
Advisor

Re: pidentd need package

Hi my friend
If when i install serviceguard-A.11.16.08-0.product.suse.i386.rpm package on suse 10 dependency error from pident package recive from system
Please help me
thanks
Serviceguard for Linux
Honored Contributor

Re: pidentd need package

Install pidentd from the SUSE enterprise 10 CD. I cannot easily look up which CD this would be on.
mas1
Advisor

Re: pidentd need package

Hi friend
Thanks for all answers for my question.
I search all medias SUSE 10 but i do not find Pident package on this.
If you know from site i can download this package, please you get that link.
Thanks Regard
Serviceguard for Linux
Honored Contributor

Re: pidentd need package

I can't check this until tomorrow my time.

I assume that you did check with

# rpm -qa | fgrep pidentd

Also, when you started the Serviceguard install, what error message did you get?
Ulf Jackisch
Occasional Visitor

Re: pidentd need package

Hello,
I try the same but when I try to install the rpm I got the following message :

node2:/tmp/install/ewg/serviceguard11.16/sources/SLES10/rpms # rpm -i serviceguard-A.11.16.08-0.product.suse.i386.rpm
It appears that an incorrect version of pidentd is loaded
For this version of Linux the version of pidentd should be:
3.1a27sg.
Check the Release Notes for the location of the pidentd rpm
file that is required here.
error: %pre(serviceguard-A.11.16.08-0.i386) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping serviceguard-A.11.16.08-0
node2:/tmp/install/ewg/serviceguard11.16/sources/SLES10/rpms # rpm -qa | grep pident
pidentd-3.1a25-199.2

The pident is the version which are coming with SLES10SP1, where can I get the necassary version or what must I do to solve the problem ?
John Bigg
Esteemed Contributor

Re: pidentd need package

mas1

The pidentd version is the same for SLES10 and SLES10sp1 and is pidentd-3.1a25-199.2.i586.rpm

I do not believe this can be downloaded and will only be found on install media. I think only updates/patches can be downloaded, not original rpms's from installs.

Sorry, I cannot tell you what CD it's on as I only have access to DVDs.

Ulf, if you get the message, "It appears that an incorrect version of pidentd is loaded
For this version of Linux the version of pidentd should be: 3.1a27sg." then you are running SLES9 not SLES10, or at least this is what /etc/SuSE-release indicates!

The script logic used here is:

if [[ -f /etc/SuSE-release ]]; then
if ( egrep 'Server.*9' /etc/SuSE-release >/dev/null 2>&1) ; then
if [[ ! -d /usr/src/pidentd-3.1a27sg ]] ;then
echo -e \
"It appears that an incorrect version of pidentd is loaded
For this version of Linux the version of pidentd should be:
\t3.1a27sg.
Check the Release Notes for the location of the pidentd rpm
file that is required here."
exit 1
fi
fi
fi
Ulf Jackisch
Occasional Visitor

Re: pidentd need package

Thank you for the hint.

I run SLES10 but I must change the version in /etc/SuSe-Release to install oracle10 and forgot it.