Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

"cmclconfd" is using obsolete set socket SO_BSDCOMPAT

kevin leong
Frequent Advisor

"cmclconfd" is using obsolete set socket SO_BSDCOMPAT

Dear All ,
I setting HP LinuxSG on DL380 G4 with MSA500 G2 .
OS version is ES 4 (i386)without update .

I successful to install the LinuxSG and bring up cluster base .During I test on fail over ,I found out on my first node (during boot process) is very slow ,on the boot.message list out process "cmclconfd" is using obsolete set socket SO_BSDCOMPAT ;process "cmcld" is using obsolete set socket SO_BSDCOMPAT .

Any problem or bug ?HOw could improve the boot porcess ?

Thanks
LeongKO
3 REPLIES
Steven E. Protter
Exalted Contributor

Re: "cmclconfd" is using obsolete set socket SO_BSDCOMPAT

Shalom,

What version of SG?

Maybe its patch or version upgrade time.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
John Bigg
Esteemed Contributor

Re: "cmclconfd" is using obsolete set socket SO_BSDCOMPAT

This is not a problem since the messages are informational. It's a warning that future versions of the kernel will remove this option which is currently being used.

Newer versions no longer use this. You need patch SGLX_00063 or newer (I think your system is 64 bit, if it's not you want the quivalent 32 bit patch). I'd suggest the latest ES 4 patch SGLX_00085.

I do not believe this message or issue will account for any slowness.
Serviceguard for Linux
Honored Contributor

Re: "cmclconfd" is using obsolete set socket SO_BSDCOMPAT

While it is not related to your direct question, you should also check the certification matrix whose link is on http://www/hp/com/info/sglx .

You will see that RH4 support starts with Update1. Your configuration is not supported.