service guard LV status Down

 
SOLVED
Go to solution
RafaelCampbell
Occasional Collector

service guard LV status Down

Hello need some help, i have this cluster the cmruncl are up both servers are running but Im having issues with the package it will not mount the FS, also checking on both nodes LV status is as follows

LV Path /dev/vg01/lvol01
LV Name lvol01
VG Name vg01
LV UUID A5NhPW-yo3s-1aBJ-dqHa-MOJY-yOcS-3Vm8Uz
LV Write Access read/write
LV Creation host, time server.name.net, 2021-01-29 02:48:37 +0000
LV Status NOT available
LV Size <200.00 GiB
Current LE 51199
Segments 1
Allocation inherit
Read ahead sectors auto

I tried to mount the FS  /dev/vg01/lvol01 but getting the following:

mount /dev/vg01/lvol01 /example/
mount: special device /dev/vg01/lvol01 does not exist

so Im guessing there is an issue with the FS, I tred to vgcahnge -a y, lvchange - ay, they activate then I again lvscan and are deactivate. Also the VG01, and VG02 are not under DEV so Im pretty confuse now, I add hosttags = 1, tried to reboot, insert the activation (hostname) file, but cant get the FS mounted pleas any help would be appreciated.

 

 

2 REPLIES 2
Mike_Chisholm
Advisor
Solution

Re: service guard LV status Down

You need to make sure you have enabled hosttags properly as it is more than simply adding that one line to lvm.conf. See the section "Enabling Volume Group Activation Protection" in the Managing HPE Serviceguard for Linux manual - https://support.hpe.com/hpesc/public/docDisplay?docLocale=en_US&docId=a00106823en_us

 

Assuming you have setup hosttags correctly, to activate the VG outside of Serviceguard requires two steps.

1) Add the tag with "vgchange --addtag $(uname -n) <vgname>"

2) Activate the VG with "vgchange -a y <vgname>"

The VG will not activate until the tag is added. You can check to see if tags are added using "vgs -o +tags". The tag should be the same thing as the node name in the cluster, which should be the same thing returned by "uname -n" as shown above. My guess is the problem is somewhere along those lines.

EDIT: I guess I should add that if you do this and then later you deactivate the VG outside of Serviceguard you must also delete the tag using "vgchange --deltag $(uname -n) <vgname>"

RafaelCampbell
Occasional Collector

Re: service guard LV status Down

Hello and thanks for the replay, we could solve the issue was on the virtual machines side, there were 2 vg that were not remove so needed to reinstall from scratch, all ok for now thanks!