HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Serviceguard
cancel
Showing results for 
Search instead for 
Did you mean: 

sglx cmmigratepkg fail to convert legacy package

 
Thian SIn
Occasional Visitor

sglx cmmigratepkg fail to convert legacy package

Hi,

im new to sglx. just update from 11.18.00 to 11.18.04 today (to get the cmmigratepkg). when i try to convert my current legacy pkg, i get the follow error.
# cmmigratepkg -p old_pkg -o new_pkg.ascii
Error: old_pkg is not a legacy package, since does not have a
control script. It can not be converted.
Package migration failed

my old_pkg.conf:
PACKAGE_NAME old_pkg
PACKAGE_TYPE FAILOVER
FAILOVER_POLICY CONFIGURED_NODE
FAILBACK_POLICY MANUAL
NODE_NAME node1
NODE_NAME node2
AUTO_RUN YES
NODE_FAIL_FAST_ENABLED NO
RUN_SCRIPT /usr/local/cmcluster/old_pkg/old_pkg.cntl
RUN_SCRIPT_TIMEOUT NO_TIMEOUT
HALT_SCRIPT /usr/local/cmcluster/old_pkg/old_pkg.cntl
HALT_SCRIPT_TIMEOUT NO_TIMEOUT
script_log_file /var/log/cmcluster/log/old_pkg.log

p/s: point only give to helpful reply.
4 REPLIES
Thian SIn
Occasional Visitor

Re: sglx cmmigratepkg fail to convert legacy package

cmviewcl output

PACKAGE STATUS STATE AUTO_RUN NODE
old_pkg up running disabled node1
Emil Velez
Honored Contributor

Re: sglx cmmigratepkg fail to convert legacy package

looks like the scripts do not exist or could not be read. Check the filenames of the old_pkg.cntl and see if that script exists.

you may have missed the pathname when you renamed them
Thian SIn
Occasional Visitor

Re: sglx cmmigratepkg fail to convert legacy package

thanks for reply. the issue here is the config syntax of legacy script. im closing this thread as i already convert legacy script into modular-base (manually edit without using cmmigratepkg).
Thian SIn
Occasional Visitor

Re: sglx cmmigratepkg fail to convert legacy package

root cause unknown