SharePoint Integration
Showing results for 
Search instead for 
Do you mean 

HP TRIM 7.12 SharePoint 2010 Integration

Frequent Visitor

HP TRIM 7.12 SharePoint 2010 Integration

[ Edited ]



I have the following setup:


1 x WFE1

1 x Central Admin CA1

1 x SQL1

1 x Office Apps server


All on SSL


I've installed the workgroup server on both WFE and CA1 and the integration on both both as well. When I click on the HP Trim button to configure the HP Dataset within CA I get "Object reference not set" In which Log files should I be lookin to get more info as the SahrePoint LOGS only give me the same info.


Any other suggestion would be appreciated. 


I did manageto get it to work in DEV which is a single server setup :( , but not in production.




Re: HP TRIM 7.12 SharePoint 2010 Integration

I would recommend using a ULS viewer to read the SP logs. Download one of the later versions of the SP documentation (7.3x) if you can get your hands on if from the HP Support site. The instructions there may help explain some of the steps to help solve your issue. It also provides a link to the ULS viewer download site. You can also just search for ULS viewer from your favorite search site.


If you are attempting to set the WAIS, and it is not finding it (as per the error), the Web Application feature probably did not activate correctly. As always, make sure all the prerequisites are set for the multiple accounts. Don't spend too much time troubleshooting this error as it may be the case that prerequisites were not in place prior to deploying the solution. You'll want to get it right from the beginning instead of patching it up in the middle.


Also, the SP integration does not need to be installed on both servers, only the CA.


Setting up the integration on 1 server does not let you enjoy all the benefits of making sure authentication works between 2 servers : )


Frequent Visitor

Re: HP TRIM 7.12 SharePoint 2010 Integration

Re-installing everything again worked, but now WAIS is not accepting the username for the TPA.



Is there a log that I can check to see the reason why it fails? I've double checked all the pre-requisites .


Re: HP TRIM 7.12 SharePoint 2010 Integration

Try providing the TPA with the User Rights Assignment of "Allow Log on Locally"  in the Local Security Policy of the WFE and APP servers.

Respected Contributor

Re: HP TRIM 7.12 SharePoint 2010 Integration


 There are few sequence steps to follow,

Prepare the system (usernames and extra as stated in the documentation for the privs.  Enable users as SP FARM and Site Collection Admin as stated in the documentation. Ideally, to the db_owner to installation user.


Please ensure that User Policy - AUthorisation has the installing / configuring user added to the zone.


Install the HP TRIM SharePoint Integration

 Reboot - so the dll can be binded correctly.


Deploy the Integeration .wsp  - Immediately do the Reset IIS and restart SP Timer  service


From the Farm  features ensure that HP TRIM Integration is Activated


From the Web Application page click the HP TRIM ribbon button.

Fillin the data and  this time it should pick up - for TPA and user account you need to provide the domain\username



Frequent Visitor

Re: HP TRIM 7.12 SharePoint 2010 Integration

Still not, I'm getting the same.


 The account details are either not correct or not suitable for this role.


I've double checked all requirements and logged in with the TPA user to confirm access to HP TRIM, SharePoint and the servers.


Are there no other logs that I can look at? Or a log level that I can increase that will give me more insight into the problem?


All your assistance is much appreciated.



Frequent Visitor

Re: HP TRIM 7.12 SharePoint 2010 Integration

Solved this problem with:


The HP TRIM TPA account MUST be administrator to ALL site collections in the web app, even the automatically created my sites.


I used this script to add the HP TRIM TPA to all the secondaryadministrator site collections


get-SPSite -Limit All|For-EachObject{set-SPSite -Identity $_.Url -SecondaryOwnerAlias domain\HPTrimTPA}