Storage Essentials Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Storage Essential 6 can't get Brocade switch

Honored Contributor

Storage Essential 6 can't get Brocade switch

[ Edited ]

I am trying to monitor Brocade switches (v5.3.0) from SE6. SE is working fine (fresh install) and able to manage the host and stoarges. Installed the Brocade SMI-Agent (120.7.1) and also tried to configure the proxy for each fabric, it's saying "Connected" so I guess it's working right.

While installation default HTTP/HTTPS port conflicted so using HP recommended 60000/60001.

While discovering the switches, it's able to ping but comes out with an error at discovery screen that it failed.

Any help is appreciated.

 

 

P.S. This thread has been moevd to Storage Essentials Support and News Forum. - Hp Forum Moderator

9 REPLIES
Honored Contributor

Re: Storage Essential 6 can't get Brocade switch

Hi,
lets start with the resume/check what has been used pls:
WBEM HTTP (SMI-S non secure) is 5988
WBEM HTTPS (SMI-S secure) is 5989
and the internal CIMOMs (Discovery groups) use the following ports:
5986 Default Discovery Group CIMOM
5984 Discovery Group 1 CIMOM
5982 Discovery Group 2 CIMOM
5980 Discovery Group 3 CIMOM
5978 Discovery Group 4 CIMOM
the pain is one part of the reality
Honored Contributor

Re: Storage Essential 6 can't get Brocade switch

and how do I check that?

Sorry but I don't recall where to find these settings.
Honored Contributor

Re: Storage Essential 6 can't get Brocade switch

Hi,
here is the installation guide:
http://bizsupport.austin.hp.com/bc/docs/support/SupportManual/c01330501/c01330501.pdf

and here is the whole SE documentation:
http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual〈=en&cc=us&docIndexId=64179&taskId=101&prodTypeId=18964&prodSeriesId=463512
the pain is one part of the reality
Honored Contributor

Re: Storage Essential 6 can't get Brocade switch

Ok,

I have confirmed that I am using the following settings:

5986 Default Discovery Group CIMOM
5984 Discovery Group 1 CIMOM
5982 Discovery Group 2 CIMOM
5980 Discovery Group 3 CIMOM
5978 Discovery Group 4 CIMOM

Any idea why it fails when I setup the discovery for Brocade switches. It says "Either a connection has not been attempted or the attempt failed on 2 IP addresses."


Honored Contributor

Re: Storage Essential 6 can't get Brocade switch

here is a short document on troubleshooting the SMI-S provider/agent,
you could also try the port 5989 as stated in this doc pls ...

http://h18006.www1.hp.com/storage/pdfs/smis_troubleshooting.pdf
the pain is one part of the reality
Honored Contributor

Re: Storage Essential 6 can't get Brocade switch

Uninstall the Brocade SMI-Agent 120.7.1; it is not supported. Get 120.6.0a and use that instead.

Note: While I work for Hewlett Packard Enterprise, all of my comments (whether noted or not), are my own and are not any official representation of the company.
----------
If my post was useful, click on my KUDOS! thumb below!
Honored Contributor

Re: Storage Essential 6 can't get Brocade switch

I thought that higher versions should always be supported but...

Install Guide says;
"Install the Brocade SMI Agent with a minimum version of 120.6.0a and configure"

Brocade support matrix doesn't talk about higher version;
"Recommended: 120.6.0a"

Anyway, my problem was solved by installing the SMIAgent on a different machine where the ports are not conflicting with default ports and I am using 5988/5989. I got the instruction to use ports 60000/60001 from "Brocade switch SMI-S provider guide" which says;
"With v110.5.0 and later of the SMI Agent, you can enter HTTP/HTTPS ports during installation. Ifthereisaconï¬ ict with ports
5988/5989, HP recommends using ports 60000/60001 for Insight Control Data Center Edition"

Looks like somehow my setup doesn't like the different ports.
Honored Contributor

Re: Storage Essential 6 can't get Brocade switch

Thread closed.
Honored Contributor

Re: Storage Essential 6 can't get Brocade switch

No, just because a particular version of something is supported, does NOT mean that any and all higher versions of it are automatically supported.

Note: While I work for Hewlett Packard Enterprise, all of my comments (whether noted or not), are my own and are not any official representation of the company.
----------
If my post was useful, click on my KUDOS! thumb below!
//Add this to "OnDomLoad" event