Storage Essentials Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Storage Essentials 6.3 - Brocade SW discovery problem

Occasional Advisor

Storage Essentials 6.3 - Brocade SW discovery problem

Hello

I have HP SIM and SE 6.3 installed in a same server windows, according to SE documentation first i must try to discover SW devices, i have 2 hp storageworks san sw but i can not see these sw, brocade smi-a 120.11.0 is already installed in a windows 2008 server; i have been testing discovery process but i can not see any sw in the SE.

Brocade SMI Agent configuration tools has 2 proxies (2 hp storageworks san sw) connected status

Any advices

Thanks
9 REPLIES
BPE
Esteemed Contributor

Re: Storage Essentials 6.3 - Brocade SW discovery problem

You can use the wbemdisco tool in the SIM main directory on the SIM Server to verify that your Brocade SMI-S Agent is really running. Perhaps the CIMON Server did not start due to some port conflicts or some firewall issues.

Next you can check the system page of the windows 2008 where the Brocade agent is running. go to the tools tab and check the system credentials You should see a WBEM entry and in newer versions of SIM also the WBEM Port.

My guess is that you do not use the standard port 5989 because it was used. If this is the case you need to edit the WBEM port list xml file in the SIM Config directory. See also SIM help page trouble shooting.
Occasional Advisor

Re: Storage Essentials 6.3 - Brocade SW discovery problem

He bpe

Thanks for your help, you are quite right, in the Brocade SMI-A (FO)installation process i changed http port configuration = 6000 and https port configuration = 6001, however when i test the comunication between SE and sw brocade device in the discovery process the port comunication are by default, attached the output:

[2010-08-14 13:09] 172.25.2.70: Probing for SMI-S Server (cxws)
[2010-08-14 13:09] cxws://172.25.2.70: No response received
[2010-08-14 13:09] 172.25.2.70: Probing for SMI-S Server (https)
[2010-08-14 13:09] https://172.25.2.70:5989: No response received
[2010-08-14 13:09] 172.25.2.70: Probing for SMI-S Server (http)
[2010-08-14 13:09] http://172.25.2.70:5988: No response received
[2010-08-14 13:10]
Origin: 172.25.2.70:
User: admin

Do you know which file i have to edit? i am not sure, i think are provides.xml or SMIConfig.xml but such as files xml i do not know how to edit it in order to change the comunication port

Thanks again
BPE
Esteemed Contributor

Re: Storage Essentials 6.3 - Brocade SW discovery problem

On the HP-SIM side I change normally the

C:\Program Files\HP\Systems Insight Manager\config\identification

But take care I never tested it together with
SE 6.3 on the same system.

I should also check the SE 6.3 documentation for details.

Occasional Advisor

Re: Storage Essentials 6.3 - Brocade SW discovery problem

Thanks again bpe, but i hab tried to chage the port in the file and it does not work either, by the way the files is c:\Program Files\HP\System Insight Manager\config\identification\wbemporlist.xml

I checked the Brocade SW firmware version 6.20g, the last version is 6.4x so i think that is recommendable to upgrade the firmware, i do not know but i can discard if is firmware problems.

Thank again.
BPE
Esteemed Contributor

Re: Storage Essentials 6.3 - Brocade SW discovery problem

I think it is still a connection issue.
Try the wbemdisco tool in the SIM main directory first. You will get a popup where you need to fill in the IP of your SMI-S Provider server, SMI-S port, Namespase for brocade is interop, the username and password.
The important part is that you are sure that a connection from the SIM server is possible and the login will work.

Here an example of a HP EVA SMI-S provider
without the graphical interface.
C:\Program Files\HP\Systems Insight Manager>wbemdisco
C:\Program Files\HP\Systems Insight Manager>echo Fri 08/13/2010 0:02:04.59
Fri 08/13/2010 0:02:04.59
C:\Program Files\HP\Systems Insight Manager>echo off
WbemDisco 01.01.00
------------------
Gui: Gui starting
Gui: Creating frame...
HOST = 192.168.xx.xx
PORT = 5989
NAMESP = interop
USER = Administrator
PASSWD = *****
Connect to 192.168.xx.xx in namespace interop with SSL=true

ObjectManager.Name=HP:CxwsCimom_192.168.xx.xx
ElementName=HP Cxws Server
CimomVersion=
Description=HP Cxws Server

Enumerating instances of CIM_RegisteredProfile
....

You should not get messages like
*** Error connecting with SSL=true - (CIM_ERR_ACCESS_DENIED) ***
or
*** Error connecting with SSL=true - CIM_ERR_INVALID_NAMESPACE: IDispatch error
#3598 (CIM_ERR_INVALID_NAMESPACE) ***
Occasional Advisor

Re: Storage Essentials 6.3 - Brocade SW discovery problem

Hi bpe

In fact i have a similar error when i tried with the wbemdisco command:

C:\Program Files\HP\Systems Insight Manager>wbemdisco 172.25.2.70 5989 interop a
dmin password

C:\Program Files\HP\Systems Insight Manager>echo Tue 08/17/2010 17:07:41.32
Tue 08/17/2010 17:07:41.32

C:\Program Files\HP\Systems Insight Manager>echo off
WbemDisco 01.01.00
------------------
HOST = 172.25.2.70
PORT = 5989
NAMESP = interop
USER = admin
PASSWD = *****
Connect to 172.25.2.70 in namespace interop with SSL=true
*** Error connecting with SSL=true - Connection refused: connect (CIMCLIENT_ERR_
CONNECTION_FAILED) ***

i did the same test with another brocade sw i got the same error, according the documentation i have to be sure the CIMON is running and from Brocade SMI Agent utility installed in HP SE server i go to start CIMON but alway show the same error.

Any advice.

Thanks
BPE
Esteemed Contributor

Re: Storage Essentials 6.3 - Brocade SW discovery problem

You can not connect directly to your SAN switches with wbemdisco. Wbemdisco should connect to your Windows system with the SMI-S provider for brocade installed. The goal is to test if your SMI-S provider is really answering your requests from the SIM/SE Server. Most of the time i saw problems with incorrect username/passwords and ports for CIMON/SMI-S.
BPE
Occasional Advisor

Re: Storage Essentials 6.3 - Brocade SW discovery problem

Thanks bpe, my mistake, however i executed the wbemdico the right way and i still can not see any sw in HP SE, from SIM are corrects but when i try to discover from SE i can not see any sw, i hab hattached the file.

I installed the Brocade SMI Agent in the same windows server but i changed the http port=60000 and https port=60001 according HP SE documentation which suggested in order to avoid port conflig.

Any advice
Occasional Advisor

Re: Storage Essentials 6.3 - Brocade SW discovery problem

Hello bpe

Thaks for everything, i solved the situation, the problem was i have to install the Brocade SMI Agent in a 32 bits windows server, now i can see my topology, brocade switch and servers, i have i new problems with the EVA4400, i see them but with ? symbol

Any advise