Storage Software
cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVMS SSSU to SMA username/password error

Carl H Fero
Advisor

OpenVMS SSSU to SMA username/password error

I have downloaded what I think is the correct version of SSSU onto my ES40 running VMS. The select manager command seems to work (and I inclded the username and password with this command). Then when I issue the select manager command or the ls command I get the error below which doesn't make sense because I am absolutely certain of the username and password (including the case sensitive).

NoSystemSelected> select system MYEVA
Error: EMClientAPITNG error ->
EMCLIENTAPI_PERMISSIONDENIED_ERROR : Invalid username or password.
13 REPLIES
marsh_1
Honored Contributor

Re: OpenVMS SSSU to SMA username/password error

hi,

if you're using vms are you putting quotes around the username and password, might be that vms has defaulted the characters to uppercase when it has sent the strings.

hth

Carl H Fero
Advisor

Re: OpenVMS SSSU to SMA username/password error

That's one combination I did't try but it didn't work...

NoSystemSelected> SELECT MANAGER 172.16.30.201 USERNAME="administrator" PASSWORD="adminISTRATOR"
NoSystemSelected> LS SYSTEM
Error: EMClientAPITNG error ->
EMCLIENTAPI_PERMISSIONDENIED_ERROR : Invalid username or password.
marsh_1
Honored Contributor

Re: OpenVMS SSSU to SMA username/password error

hi,

is this the username/password for the eva cv agent or the management appliance ?

Carl H Fero
Advisor

Re: OpenVMS SSSU to SMA username/password error

Must be the password for the SMA. I open up a browser and browse to the IP address of the SMA then use this username/password. Then I click on the "devices" icon and then click on the "command view" icon and voila I have acces to my eva. This was all set up for us by an outside vendor.
Víctor Cespón
Honored Contributor

Re: OpenVMS SSSU to SMA username/password error

What version of SSSU and what version of COmmand View? This can happen when the versions do not match.

Also, there was a similar issue on HP-UX 11.11 where you needed to install OpenSSL.
Carl H Fero
Advisor

Re: OpenVMS SSSU to SMA username/password error

How do I verify what version of Command View is installed on the SMA? This was vendor loaded for us 3 years ago. I took an educated guess and downloaded this older version of SSSU to my VMS box...

SSSU for HP StorageWorks Command View EVA 4.00 [v4.0.18]
Víctor Cespón
Honored Contributor

Re: OpenVMS SSSU to SMA username/password error

In the Command View login screen, it's displayed usually the version. Or once inside, got help - about.
Carl H Fero
Advisor

Re: OpenVMS SSSU to SMA username/password error

Found it under the "Help". Thanks. I am at V2.1 of HP Openview SMA Software. So I have the right version of SSSU V4.0.18 loaded on my Alpha. Now it may come down to whether I have the right password. I think I am using the SMA password and not the command view password. Thanks.
Carl H Fero
Advisor

Re: OpenVMS SSSU to SMA username/password error

I'm in. I'm in.

I found an old forum thread from 2004 with the same password error and it recommended using administrator as both the username and password and it worked! Now I can do the capture config and feel a little safer in an emergency. Thanks for everyone's help on this. It's my first time using this forum and it was so helpful. I'll make sure I give everyone points (as soon as I figure that out). Everyone have a good weekend.
Uwe Zessin
Honored Contributor

Re: OpenVMS SSSU to SMA username/password error

Important is the version of CV-EVA, not that of the SMA's management framework. CV-EVA V4 lives as part of the "System Management Homepage" (SMA) and uses its authentication mechanism.

If you change that password, you must update CV-EVA, too:
> C:
> cd "\Program Files\Hewlett-Packard\SANworks\Element Manager for StorageWorks HSV\Bin"

> elmsetup -pA:ThePassword -f

> net stop "HP Command View EVA"
> net start "HP Command View EVA"
> net stop "HP System Management Homepage"
> net start "HP System Management Homepage"

If that does not help, reboot the SMA - that has always been a good thing...
.
marsh_1
Honored Contributor

Re: OpenVMS SSSU to SMA username/password error

hi,

remember to also close the thread you had open on the vms forum on this topic.

Carl H Fero
Advisor

Re: OpenVMS SSSU to SMA username/password error

Thanks for everyone's input. It was my first time using this forum and was very successful for me. I found the answer in the "storage" forum and have done the capture configuration today for my EVA5000. Thanks again!
Carl H Fero
Advisor

Re: OpenVMS SSSU to SMA username/password error

Sorry I opened this and bothered anyone! I just found the solution. My error!