Storage Software
cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with SSSU "losing" commands.

Ira Carmel2
Occasional Visitor

Problems with SSSU "losing" commands.

Hey folks, I need some help. I have some pretty elaborate SSSU scripts to do snaps associated with our database nightly freeze and backup. The problem is logged in case 3212423197 but I thought I might post here because it hasn't been resolved yet and it is pretty urgent.

Problem description:

SSSU scripts issuing the add lun or delete lun command hang, and never complete. When I investigate using the command view, everything seems ok, and I can issue the same command again from another SSSU session and it completes correctly.

I have synchronized batch jobs running, so when the snap creation or deletion finishes I can move ahead to the next step. Since it hangs, I am forced to do the lun creation and delete the batch job myself (by hand) to allow the next step to complete.

Versioning information:

VMS 7.3-2

SSSU for HP StorageWorks Command View EVA 4.00 [v4.0.18]

Command View EVA 4.1.0.20

SSSU version on the appliance:

SSSU for HP StorageWorks Command View EVA 4.00 [v4.0.18]

Other anecdotal information. Our HP engineer recently tried to run a SSSU script after an upgrade to "show" everything, and it never finished. This program was a .bat file running on the appliance. It did things like show disk show power show bla bla bla. It showed every possible item to a log file so he could have a foodprint of our system.

It has been proposed that perhaps I am issuing too many add snap add lun commands at the same time. At first I was issuing 20 snap creations at once. But upon the suggestion of the engineer, I added delays of 5 seconds in between each creation. Does anyone else have a setup like this? If so are you having any problems scripting the SAN appliance?

-Ira carmeli@sutterhealth.org
1 REPLY
Mike Reznak
Trusted Contributor

Re: Problems with SSSU "losing" commands.

Hi,
we experienced such things only when two simultaneous sssu operation ran together. We tried to analyze CV Appliance but found nothing except the CV proces was running heavily. So its recomended to access Appliance only one session at the time (even web based management).

Mike
...and I think to myself, what a wonderful world ;o)