Storage Software
cancel
Showing results for 
Search instead for 
Did you mean: 

multiple snapclone restores using RSM or SSSU

Karen Dorhamer
Occasional Contributor

multiple snapclone restores using RSM or SSSU

We have snapclones of the LUNs containing an Oracle database and would like to restore the original copy of the database from the snapclones before each run of a benchmark. We used Command View 9.01 to create the snapclones. We then used Replication Storage Manager 5.0.18 to restore the database from the snapclones. This worked successfully the first time, but the next time that we tried to do a restore (by right clicking on the vdisk to restore to and selecting Instant Restore), the snapclone does not appear in the list of sources to restore from. Does the RSM GUI only allow a single restore from a snapclone? Or are we using the wrong procedures?

We also tried to use the SSSU command line to restore the snapclone, but received the following error:

Fred> set vdisk "\Virtual Disks\Vdisk016-test" restore source_vdisk="\Virtual Disks\Copy of Vdisk016-test"

Error: Error cannot modify object properties. [Object ID provided, or object typ
e, is invalid for the requested operation.]

Did we use the wrong command or the wrong syntax? In this case "Vdisk016-test" is the vdisk that we want to restore to and "Copy of Vidsk016-test" is the snapclone.

Here is the output of the "ls vdisk" command:
Fred> ls vdisk

Vdisks available on this Cell:
\Virtual Disks\Copy of Vdisk001 R10\ACTIVE
\Virtual Disks\Copy of Vdisk001 orig\ACTIVE
\Virtual Disks\Copy of Vdisk002 R10\ACTIVE
\Virtual Disks\Copy of Vdisk002 orig\ACTIVE
\Virtual Disks\Copy of Vdisk003 R10\ACTIVE
\Virtual Disks\Copy of Vdisk003 orig\ACTIVE
\Virtual Disks\Copy of Vdisk004 R10\ACTIVE
\Virtual Disks\Copy of Vdisk004 orig\ACTIVE
\Virtual Disks\Copy of Vdisk005 R10\ACTIVE
\Virtual Disks\Copy of Vdisk005 orig\ACTIVE
\Virtual Disks\Copy of Vdisk016-test\ACTIVE
\Virtual Disks\Vdisk001\ACTIVE
\Virtual Disks\Vdisk002\ACTIVE
\Virtual Disks\Vdisk003\ACTIVE
\Virtual Disks\Vdisk004\ACTIVE
\Virtual Disks\Vdisk005\ACTIVE
\Virtual Disks\Vdisk007\ACTIVE
\Virtual Disks\Vdisk008-fscopy-data\ACTIVE
\Virtual Disks\Vdisk009-fscopy-index\ACTIVE
\Virtual Disks\Vdisk010-fscopy-redo\ACTIVE
\Virtual Disks\Vdisk011-fscopy-temp\ACTIVE
\Virtual Disks\Vdisk012-fscopy-expdump\ACTIVE
\Virtual Disks\Vdisk013-fscopy-undo\ACTIVE
\Virtual Disks\Vdisk015-orabck-vraid5\ACTIVE
\Virtual Disks\Vdisk016-test\ACTIVE

Thanks,
Karen

p.s. my apologies if this is a duplicate post. I had entered a similar post yesterday, but am unable to find it today.
2 REPLIES
MR Dorobantu Dragos
Frequent Advisor

Re: multiple snapclone restores using RSM or SSSU

Hello,

I have the same situation. Did you find the sollution?
Karen Dorhamer
Occasional Contributor

Re: multiple snapclone restores using RSM or SSSU

No, I did not find a solution, but I worked around it by presenting the snapclone copies to the server and copying the data from the snapclone copies to the original filesystem.

Karen