StoreEasy Storage

1000s locks up during nfs backup

 
CA1098907
New Member

1000s locks up during nfs backup

Hi,

we have a 1000s server and it locks up when our servers backup to it via NFS. I should point out that the server is not completely dead. The mouse point still moves and I can ping the server ok but gui/nfs/smb/telnet basically all else is not responding.

The server is running w2k SP4 + NAS 2.01 SP1a + SFU 2.x + (Patches 330032,839302).

There is possibly another patch installed, Q327473, but I've only found it mentioned in a readme file. There is no mention of it in Add/Remove Programs.

The nfs clients are mostly RHEL v3 with very recent kernels (2.4.21-27.0.x). There is also a RH8 and a SCO box as well.

The server locks up during RHEL backups but it is not consistent. Yesterday it locked up during one server while today it locked up during the backup of another.

the NFS share is mounted with the following options,

rsize=8192,wsize=8192,intr

Reading through this forum I've noticed people suggesting the possible causes for nfs hangs to be bad block side, I've seen recommendations of a block size of 32k and possible resource starvation on the server.

Looking at Microsoft's website I've noticed that we are running a quite old version of SFU. Would upgrading to version 3.5 be of help?

Any help would be appreciated.

Regards,

Greg.
1 REPLY 1
CA1118839
Valued Contributor

Re: 1000s locks up during nfs backup

Greg,

Yes, try increasing the read/write buffer size by changing the mount option to:

mount -o rsize=32768, wsize=32768 server:/share /mount

To restart the NFS service, do the following:

1. Open a command prompt
2. Type net stop nfssvc
3. Type net start nfssvc