StoreEasy Storage

Logical Drive with Background parity error on HP storage server

 
Jon Sumida
Occasional Advisor

Logical Drive with Background parity error on HP storage server

I hope this is the right place for this. I have a HP Proliant DL185G5 Storage Server. I ran the Array Diagnostic Utility and it returns the following error:

 

Background parity initialization is currently queued or in progress on this logical drive. If background parity initialization is queued, it will start when I/O is performed on the drive. When background parity initialization completes, the performance of the logical drive will improve.

 

I don't know how long it's been doing this as I haven't had to really run diagnostic on this drive before. I only did so today because one of my 1TB drives failed so I pulled it out and swapped in another one. Could this be the reason I see this message or are the 2 events completely unrelated? I'm basically a newbie when it comes to storage/array things as I inherited this server from an ex-coworker and now have to manage it.  Any suggestions will be greatly appreciated.

2 REPLIES 2
Carlton Bickford
Occasional Advisor

Re: Logical Drive with Background parity error on HP storage server

Yes, that informational message is most likely because you swapped out a physical drive. The logical drive in question is likely configured as RAID 5 or 6, so the data has to be re-striped accross the physical drives that make up that logical drive.  This is expected behavior, and for large drives this can take a long time (days), especially if the logical drive is in use (i.e. experiencing I/O. )

 

Use the Array Configuration Utility (probably at programs->HP System Tools) to see more information about the layout of physical drives that make up your logical drives, RAID level, status, initialization progess, etc.

Jon Sumida
Occasional Advisor

Re: Logical Drive with Background parity error on HP storage server

Hmm. Okay. I had replaced the drive last week. Should it be this long?

 

When I access ACU and look at my Smart Array P800, it shows now status alerts. When I run Diagnostics through this that same error message no longer appears. But when I re-run the ADU that parity initilization error still shows up for Logical Drive 3.  Why is there conflicting reports?