StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't Remove No H/W Device

Yohanes_1
Occasional Contributor

Can't Remove No H/W Device

Hi,

I have problem to remove Unclaimed Device. Any body can help me how to remove it ?

Here is status by Ioscan command :

#ioscan -nfCtape
autoch 0 0/9/0/0.97.15.255.1.3.0 schgr HO_HW DEVICE STK L20

I tried to remove driver by SAM and reboot the server but when i tried to ioscan the status still showing.

Please Help.

Thanks.

Yohanes Tjie
2 REPLIES
Luk Vandenbussche
Honored Contributor

Re: Can't Remove No H/W Device

Hi,

Have you also physically removed the tape drive?
Did you remove autoch and schgr from the kernel.

What is de device file?
Can you try to remove the device file with
rmsf
Scott McIntosh_2
Honored Contributor

Re: Can't Remove No H/W Device

It's on a SAN, so possibly the FC/SCSI bridge the L20 is behind is still advertising itself but some kind of security is blocking it?

I find it odd -fnCtape reported an autoch class device.

So is the L20 still on the SAN? Maybe it's just zoned so it can't be seen, but the name server in the switch is still telling about it?

Since you rebooted, I would think any cache of the device in the iotree would be wiped clean, so the server must be relearning of the device from the SAN.