StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot Eject - "No mail slots defined"

Mark_364
Occasional Advisor

Cannot Eject - "No mail slots defined"

Hi - I have received the HP Storageworks vs80 1/8 autoloader. When I try to eject a tape from Data Protector s/ware, I get this: "SCSI-II library cannot eject the specified medium because library has no mailslots. "
How do I do define these? Backups appear to be working correctly.
4 REPLIES
Mark Grant
Honored Contributor

Re: Cannot Eject - "No mail slots defined"

These are not defined within DP but are defined within the library itself. Now I believe that this library reports it doesn't have a mailslot although it seems that it does. It might be possible to configure the library via menu options to report that it does have one but I susepect this is why DP can't see it.

With no mailslot, DP can't eject a tape. Generally it doesn' really matter becuase you can load tapes into the slots yourself, all it means really is that the library has to re-scan it's contents everytime you load/unload tapes.
Never preceed any demonstration with anything more predictive than "watch this"
Mark_364
Occasional Advisor

Re: Cannot Eject - "No mail slots defined"

Thanks for the quick response - but I'm really having trouble just to define this "mail slot"? Could the tape drive be malfunctioning?
Kurt Beyers.
Honored Contributor

Re: Cannot Eject - "No mail slots defined"

Mark,

the mailslot of your autoloader is just the entry/exit slot. A 'real' mailslot does not exist in the autoloader.

Just unload the wanted tape from the library menu itself. Perform then a library scan from DP:

omnimm -repository_update DriveName [-slot SlotID]

Kurt
Mark_364
Occasional Advisor

Re: Cannot Eject - "No mail slots defined"

ok, thanks for that Kurt - Finally managed to get it to do the "simplest" of tasks, by 1st unloading the tape then running exporting from the library control panel. Cannot get it to eject from DP - but not a biggie.