StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

Cannot Update Firmware on DLT/20

Ayman Altounji
Valued Contributor

Cannot Update Firmware on DLT/20

Hi All,

We have several CPQ DLT 20/40 drivers and these drive have old firmware
(d887) we would like to updated the firwmare of these drives as they cause several problems with Arcserve.

Currently installed TSMC tools to update the firmware, we can succefully login and connet to the tapedrive and see the current version of the firmware.

When we do the automatic feature it list the Newer version of the firmware to use, and as soon as we click on " USE IT " it tries to download the firmware and it stops at 75% each time!

Where can we manually download these files and where should they be places at the server,? If we click the manual option in the tool it's say there are no files located.

Also tried the softpacks, but am unsure which one to use, there are several, and most of the i have tried to use the bootable disk but still am unable to succesfully flash the tape streamer.

Who can tell me how to solve this or where to download the firmware for a CPQ DLT 20/40 External tape drive

Best regards,
Janine Bertolo
Honored Contributor

Re: Cannot Update Firmware on DLT/20


As an alternative to the TSMC, you can download SP16275 from our website at:

Each disk in the set is bootable. Unfortunately, the site does not distinguish between the internal and external models of the drive.

If you create disks 6 and 9, you will have covered all your bases. If you boot up to the wrong disk, you will simply get a message saying that there are no upgradeable devices attached to the controller. Use the other floppy at next boot and you should be able to update the drive firmware.

The firmware upgrade, along with all the available patches from Computer Associates, should resolve your issues.

If you have any further questions, you can email me at
To get results you've never had before, try something you've never tried before.