StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

Cannot write to tape drive

Cannot write to tape drive

We have changed at out customers site the SAN, backup part. Before we had two separate tape libraries, now one (pass-through mech). Before only two SCSI ports on the MDR where used, now all the four SCSI ports. We introduced StorageNodes.

2 fabrics of each 2 SAN Switches (1Gb-FC SAN Switch 16 and 2/16EL + 1 ISL)
2 HSG80's V86F and V87F
1 EVA3000 v3010
2 MSL5026 tape libraries (Master/Slave0) connected via MDR
10 Windows 2000/2003 each via KGPSA FC HBAs
1 HP-UX 11i via A6795A HBA

The following zoning is configured:
1 zone for each Win2k/win2k3 server
1 zone for HP-UX
1 zone for backup, the backup zone has only Win2k/win2k3

The Backup software is Legato 7.1.2 (clients 7.1.1)

The following problem comes up:

During backup, a lot of Event IDs 15, 11 en 9 come up in the event log. There are three StorageNodes and only one is functional (at the 1 Gb SAN switch side). The other two (at the 2 Gb switch side) cannot write data to the tape drive. I can use the "inquire -l" command from Legato to go out and do a low level SCSI probe, everything looks fine.

We are already in contact with HP.

The driver for the KGPSA HBA is 5-4.82a16 with firmware 3.92a2-1.70a1
All the other firmware is at the latest level.

Things we have already tried:
- disabled Fibre Information Agent
- stopped/disabled RSM
- disabled SSP on the MDR
- changed ResetTPRLO from 2 to 1

Has anyone expirienced those problems and how can we rid of them?

Thank you for your help



P.S> THis thread has been moved from general to Tape Libraries and Drives.  - Hp Forum Moderator

Stuart Whitby
Trusted Contributor

Re: Cannot write to tape drive


I don't deal much with this stuff at the hardware side, but I do use a fibre analyser to try to figure out these kinds of problems on occasion (don't ask). I know that with the analyser, I need to explicitly set it for 1 or 2Gb operation. Could this be your problem with the 2 storage nodes?

Do you have any error messages from the daemon.log while trying to write to these drives? Also, can you post examples of the messages you see in the event log? This should help me get a better idea of the problem.


A sysadmin should never cross his fingers in the hope commands will work. Makes for a lot of mistakes while typing.

Re: Cannot write to tape drive

Hi Stuart,

See the attachement for the logs you request.

BTW, alice = backup server (Win2k)
slim + stanley + snowwhite = storagenode (Win2k3), only Win2k3 have problems, like event logs 9, 11 and 15!!!

Last Saturday HP did a lot of troubleshooting at the customer side, but did not found the answer. At the end of the 8 hours troubleshooting session they suspect Windows 2003...will be continued...

best regards,
florence mathon lermusi
Trusted Contributor

Re: Cannot write to tape drive


is it the first try to backup after implementation or did it work before ? In this last case, what kind of change have been made to the platform ?
Stuart Whitby
Trusted Contributor

Re: Cannot write to tape drive

OK, this looks like a problem with the drivers for your HBA card. There's a similar discussion on which covers event 15 - device not ready yet. Somehow, your install seems to be broken so that the "device not ready" message is not shown, and you get the unknown error in your event log instead.

I've actually got 2 suggestions here. Firstly, reinstall the drivers for your HBA. You may want to take note of the discussion in the above thread and install an older driver level. Secondly, the device not ready could be a case of the tape being loaded in the drive correctly but not being ready for use as yet during the initial "handshaking" of the tape in the drive. You can increase the time that NetWorker will give this tape to load by increasing the load_sleep parameter for the jukebox. The default is 5 seconds; I'd try increasing this to 60 to see if it makes a difference. If this works, then tune it back down to get some performance from your tape loads rather than waiting a minute during each and every load of a tape into a drive.

Good luck...
A sysadmin should never cross his fingers in the hope commands will work. Makes for a lot of mistakes while typing.

Re: Cannot write to tape drive

Hi Mathon,

Before Monday September 20th we only got one backup server (alice), with MDR and two separate MSL5026 tape libraries. Because of the backup window we introduced storagenodes and pass-through mechanism.
The MDR has a quad SCSI module where only SCSI port A and C are used.

After Monday Sept. 20th, we had one master/slave0 tape library, connected to all four ports of the MDR. library+drive0 to A, drive1 to B, drive2 to C and drive3 to D. In Legato three storagenodes are configured, all Windows 2003 (backup server is Windows 2000).

Backup operation storagenodes:
We can see that the tape is loaded in the tape drive. At the moment that data should be written to the tape it stops! A few minutes later event ids 9, 11 and 15 appear in the event log. After a while the tape is marked as FULL.

Jim Casselman_2
Occasional Advisor

Re: Cannot write to tape drive

I have a customer with the same issue, though they are using an EVA VCS 2.002, Legato Networker 6.1.3, and a QualStar 4660 library. I believe the ResetTPRLO should be set to "2" instead of "1" per the HP EBS design guide, though I don't know if it would resolve those errors you are describing. I have yet to update the firmware, and ResetTPRLO settings on all StorageNodes as this requires a scheduled outage. I'd like to hear from you if you have resolved this problem.

Re: Cannot write to tape drive

Hi Jim,

Yes, we solved our problems. On the ISL where a lot of errors, we changed the 1Gb SFP. The same ISL on the 2Gb side was connected to port 15. After some try-on-error procedures we changed it to port 14. No FC cable change no SFP change on the 2Gb side. But after the physical port change, no more error occur. So we need to totally swap the SAN switch.

Re: Cannot write to tape drive

See the thread in front of this...It was hardware related.