StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Compaq 20 40 DLT Lib not working on W2K Server

Tom Carrellas
Occasional Contributor

Compaq 20 40 DLT Lib not working on W2K Server

Recently upgraded a Windows NT 4.0 server to Windows 2000 SP3. Upgraded from BackupExec 7.2 to BackupExec 9.0 server editions. The robotic library on this Compaq 20/40 DLT tape drive worked fine under WINNT 4.0 BKEXEC 7.2. Since the upgrade to WIN2000 the media changer and tape drive install fine on the server, however, neither the OS's Removable Storage Service or BKEXEC communicate with the robotic library. This tape drive is on the WINY2K HCL and is supported by Veritas's BKEXEC. Both drive and media changer using latest firmware V4.06. Appreciate any help with our situation. Attached is screen shot of device manager showing drive and media changer.
6 REPLIES
Eugeny Brychkov
Honored Contributor

Re: Compaq 20 40 DLT Lib not working on W2K Server

Tom,
what library is it? Did you try installing SoftPaq software for it?
From the picure I see CPQ DLT4000 drive, and I see changer mech for 2/15 HP library (HP C5173-4000, disabled) in RSM section.
If this is a CPQ library you're talking about - changer C5173-4000 and DLT4000 drive then I do not see problems with them. Drive is claimed, changer is disabled in RSM because you're using BacupExec.
Did you try to stop RSM service at all and then using BackupExec?
Eugeny
Tom Carrellas
Occasional Contributor

Re: Compaq 20 40 DLT Lib not working on W2K Server

Eugeny,
I have disabled RSM and BkExec still does not pick it up. Between the two RSM and BkExec do not seem to communicate with the DLT library. I have tried just using RSM or just BKEXEC and both do not detect the library. The drive is present but I cannot operate the tape drive without the library.

The drive and library are present in the BIOS and the Device Manager. The driver for the Library is taken from Microsoft, dated July 18, 2002 V 5.0.2195.5438. The tape drive is using a Quantum driver supplied by the Veritas (BackupExec). In BKEXEC when I tried to apply simply Veritas drivers it only detects the tape drive and considers it a stand alone drive, the robotic library does not display.

Appreciate any ideas you can shed on this. The confusing part about this is that between Windows 2000 and Veritas this DLT Library should be supported.
Eugeny Brychkov
Honored Contributor

Re: Compaq 20 40 DLT Lib not working on W2K Server

I have an idea... Did you install BackupExec with enabled RSM? Try to disable it and reinstall BackupExec loading its native drivers. You have to manage to do it, otherwise BackupExec will refuse to work with library
Eugeny
Tom Carrellas
Occasional Contributor

Re: Compaq 20 40 DLT Lib not working on W2K Server

Eugeny,

I have disabled RSM and reloaded the tape drive via Veritas BKEXEC. Still unable to locate the robotic library in BKEXEC. However I think I may just uninstall BKEXEC and reinstall it with RSM disabled to see how that goes. I will probably do that Monday evening. I appeciate your input. I will keep you posted.

Tom Carrellas
Tom Carrellas
Occasional Contributor

Re: Compaq 20 40 DLT Lib not working on W2K Server

Eugeny,

I am happy to report that I have gotten the drive back into service. After working on this for the past couple of weeks I decided to start from the beginning.

I uninstalled the installation of BKEXEC 9.0 and also disabled the Windows 2000 service, Removable Storage Manager. I simply reinstalled the BKEXEC software. During the initial installation the BKEXEC walks you through a device configuration wizard and I was elated to see the robotic library was detected. My theory is that the RSM and BKEXEC devices managers were competing for the device. By keeping RSM disabled I think I was able to let BKEXEC perform it's job in detecting and securing the devices during the installation.

Thanks for your help in evaluating my problem. Your suggestion that my configuration looked okay gave me the confidence to keep trying. I sincerely appreciate your help.
David Holbrook
Regular Advisor

Re: Compaq 20 40 DLT Lib not working on W2K Server

For what ever it is worth, my experience with Veritas software is that if you make ANY changes to the hardware or software, it will no longer recognize the tape library. You have a double wammy, you changed the OS AND changed the Veritas software. Typically this can be corrected by deleting the old tape drive in the Veritas software, rebooting, and letting the Veritas software now find the "new" drive. You have accomplished the same thing by de-installing the software and re-installing the Veritas software, which now "finds" the "new" hardware. Good luck, David