StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

DP 5.5 sees drive and library seperately

Torren Craigie-Manson
Occasional Advisor

DP 5.5 sees drive and library seperately

Hi,

I have DP 5.5, one cell, all servers are Windows Server 2003. I have a nice new StorageTek L20 that I've attached to a client.

Doing an "Autoconfigure Devices" finds both the drive and library as seperate. The library has a "No drives found" message under it during the autoconfigure in DP.

The Windows Removable Storage service is disabled, and in device manager, the "Unknown Medium Changer" is disabled.

Devbra says:

C:\Program Files\OmniBack\bin>devbra -dev

Exch STK:L20 Path: "scsi2:0:6:0" SN: "ITSASECRET"
Description: StorageTek L20 Tape Library
Revision: 0214 Flags: 0x0006 Slots: 0 Drives: 0
Drive(s) SN: "N/A"

Tape HP:Ultrium 2-SCSI Path: "scsi2:0:5:0" SN: "N/A"
Description: HP LTO drive
Revision: F350 Device type: lto [13] Flags: 0x0001

C:\Program Files\OmniBack\bin>

Any thoughts on other things to poke at?
6 REPLIES
Kurt Beyers.
Honored Contributor

Re: DP 5.5 sees drive and library seperately

Torren,

Just define the library manually in the DP GUI using the hardware paths for the library and the tape drive found in the output of 'devbra -dev'

Kurt
Torren Craigie-Manson
Occasional Advisor

Re: DP 5.5 sees drive and library seperately

Hi,

I can get everything setup that way, but it doesn't work right. If I try a barcode scan, I get:

[Normal] From: UMA@server.domain.com "Server_L20" Time: 3/21/2005 1:30:37 PM
STARTING Media Agent "Server_L20"

[Critical] From: UMA@server.domain.com "Server_L20" Time: 3/21/2005 1:30:42 PM
[90:59] scsi2:0:6:0
Cannot open exchanger control device (Device type mismatch)

[Critical] From: UMA@server.domain.com "Server_L20" Time: 3/21/2005 1:30:42 PM
[90:59] server.domain.com : scsi2:0:6:0
Cannot open exchanger control device ([1117] The request could not be performed because of an I/O device error. )

[Normal] From: UMA@server.domain.com "Server_L20" Time: 3/21/2005 1:30:42 PM
ABORTED Media Agent "Server_L20"


============================================================================
0 cartridges out of 0 successfully scanned.
============================================================================
Kurt Beyers.
Honored Contributor

Re: DP 5.5 sees drive and library seperately

Is the 'Removable Storage' service disabled on the server?

Reboot the server and the NSR if the library is SAN attached once.

Kurt
Torren Craigie-Manson
Occasional Advisor

Re: DP 5.5 sees drive and library seperately

Hi,

Removable storage is disabled, and the library is disabled in device manager.

The library is SCSI attached to a server.

Torren Craigie-Manson
Occasional Advisor

Re: DP 5.5 sees drive and library seperately

Fixed!

Another server reboot did the trick...

Thanks for your help,
Torren
Torren Craigie-Manson
Occasional Advisor

Re: DP 5.5 sees drive and library seperately

A Reboot did the trick.