StoreEver Tape Storage

Re: Dataprotector Express SSE - Error code 59 (0x3b)

Kate Mallatratt
New Member

Dataprotector Express SSE - Error code 59 (0x3b)

Message: service not found.

I cannot get this software to work at all. I came in Monday morning to find the backup had not worked. Tried to login to the admin interface & the above message came up. I have uninstalled it & reinstalled, patched with SP4 but to no avail.

All the associated services are up & running, only one I've noticed a problem with is Removable storage, which is disabled. When I enable it & put it on automatic, it reverts to disabled on its own.
Please help as I havent backed up since Thursday now!!
D Lancaster
Honored Contributor

Re: Dataprotector Express SSE - Error code 59 (0x3b)

This is usually a permissions problem. The User Account or the Data Protector Express Service does not have sufficient privileges to be able to access the data.

Make sure that you are logged on as an Administrator or Backup Operator and that the Data Protector Express service has logon privileges that are sufficient to gain access to any drives.

By default the Data Protector Express Service runs in the SYSTEM account context. This account, or the currently logged on User Account must have explicitly defined Full Control Permissions to all directories or files that Data Protector Express will back up.

Dave L

Re: Dataprotector Express SSE - Error code 59 (0x3b)

I have got the same problem, and tried everything. The backup was running perfectly and suddenly stopped working. When I restarted the server on some given day I got this error 59 and "The desired service was not found. Either the service is no longer active, or the machine providing the service is unavailable at this time"

and with no possibility in starting up the software. This is a major issue cause we must back-up.

The software uses the system account and has all the appropiate rights. I also used the administrator for trial. I also upgraded to SP4 and this didn't seem to work either.

Has anyone a clue because this is a big issue for us!
thank you in advance.
D Lancaster
Honored Contributor

Re: Dataprotector Express SSE - Error code 59 (0x3b)

Hi Erik,

There are a couple of other things to check depending on your configuration.

First, make sure the service dpwinsvc is running (I am assuming this is a Windows Server). If it is loaded but not running try to manually start the service.

Next, when you reinstalled did you re-enter your license key?

Next, what other software did you install or update about the same time DP Express stopped working? Anti-spyware and firewall sofware often get in the way.

Finally, how many machines are in your backup domain and which machines are giving you the message? With more than one machine we have seen this to be caused by network problems.

I hope one of these ideas might help.

Dave L

Re: Dataprotector Express SSE - Error code 59 (0x3b)

I have the same problem with DP Express but not SSE edition. It is on all the servers I have installed - even on the one DPE is running

I tried everything I was able to think of - restarted the services, the server itself - still nothing.

But CLI util says opposite:
C:\Program Files\HP\Data Protector Express\v3.50-sp2\win\x86>dpwinsvc -q

Data Protector Express Service Control Manager
Version 3.50-sp2 (Build 34497)
Copyright (c) 2007 Hewlett Packard Development Company, L.P.

Status : Running Service
: The service is running

I am attaching the screen shot.

By the way is there a list of all (or most common) error codes with descriptions?

Aurelijus Astrauskas
D Wong
Regular Advisor

Re: Dataprotector Express SSE - Error code 59 (0x3b)


Try upgrading to the latest hotfix Build 37634 version of DPX 3.5 SP2. There were some gui issues in the earlier build of SP2.

Here is a hyperlink to the CDROM iso image.

Re: Dataprotector Express SSE - Error code 59 (0x3b)

I installed the latest version of DPE 3.5 SP2 but it still does the same thing. Haven't tried to restart the whole server after update but hardly believe that it is going to help here.

It is strange why it stopped without any notice because it was running fine since first days of this year - so what could make it stop working? I am not letting to do updates automaticaly, just notify.
D Wong
Regular Advisor

Re: Dataprotector Express SSE - Error code 59 (0x3b)


Try looking in Windows System and Application Event log to see why DPX services are failing to start.

Also, if you have not already tried, try to reboot your DPX server machine.

One other suggestion, look in the DPX \install directory\log\ for the dptrace*.txt files to see why DPX services are not starting.

Don Y
Occasional Contributor

Re: Dataprotector Express SSE - Error code 59 (0x3b)

I just encountered the same thing this week with a system running DPE SSE 3.50sp2 build 34497. It had been running properly already for several months, with a valid license,etc. I have tried to perform upgrade using the build 37634 of 3.50sp2 and it complained about various files it could not copy. Since I couldn't upgrade without error, I have now removed DPE and will be reinstalling again from scratch. Has anyone found an error code reference anywhere, or a reason for these Error Code 59?

André Noordermeer
Frequent Advisor

Re: Dataprotector Express SSE - Error code 59 (0x3b)

I've got the same thing, haven't found a cure yet.
I'm running DPE-SSE on WinSrvr2008.
There are some compatibility issues, but generally it ran fine until last Tuesday night there were Windows Updates requiring a reboot.
I can't see any relation to any specific update that came in though. Must be something there, I'm sure. Too much of a coincidence.
Whatever service it's complaining about I don't know, all services are actually running ok.