StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

ESL322e Firmware Mismatch?

J Borgia
Advisor

ESL322e Firmware Mismatch?

I have an ESL322e Tape Library that I was just trying to update the firmware on. The latest version for this platform is 6.0. It installed fine on the system, but now CommandView TL says that the robotics are not ready and there is a firmware mismatch.

Anyone seen anything like this before? It's not like I'm running some old MSL5000 series library. This should work.
6 REPLIES
Curtis Ballard
Honored Contributor

Re: ESL322e Firmware Mismatch?

Have you updated the firmware on the Interface Manager?

Did you update the firmware for the library using CV-TL?
J Borgia
Advisor

Re: ESL322e Firmware Mismatch?

I tried to upgrade the firmware to l220. It only seems to want to go to l180. Now that the library is not in a "ready" state, it will not upgrade the interface manager to l220.

I am attempting these upgrades with CV TL.

Any ideas? The downgrade option was not selectable during the upgrade, so it does not appear that I can easily downgrade with CV TL.
Curtis Ballard
Honored Contributor

Re: ESL322e Firmware Mismatch?

Try to redownload the library firmware using CV-TL and the same library firmware revision. That should clear the FW mismatch and allow updating to I220.

If you need to downgrade back to the original firmware revision call your local HP tech support number and request an L&TT password. That password will allow downgrading with CV-TL.
J Borgia
Advisor

Re: ESL322e Firmware Mismatch?

It is the library firmware "Robotics" in CV-TL that claims to have the mismatch, not the Interface Manager. The current revision of Robotics is listed in CV-TL as 6.0, which actually is the current version. That's where the mismatch is. When I try to redownload the version 6.0 to the library to attempt to install over the top of the existing 6.0, it grays out the box to select it, so I can't. Guess I have to call HP support to see if they can help me downgrade.
Curtis Ballard
Honored Contributor

Re: ESL322e Firmware Mismatch?

Yes call tech support and get a password to downgrade which should allow you to either re-download 6.0 or downgrade.

I think you should also be able to use the command line download - ftp the older firmware file onto the the library and then run the CLI to update the firmware.

The Interface Manager is the component that has decided there is a firmware mismatch and the firmware mismatch algorithm was redone with IM200 so upgrading would take care of the mismatch unfortunately an upgrade from 1.X to 2.X requires green status first.
J Borgia
Advisor

Re: ESL322e Firmware Mismatch?

Yup. I called HP earlier this afternoon. They gave me the password, and we were able to re-download 6.0, then re-load i220 for the Interface Manager. All is happy now. Thanks for the help.