StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Fiber connected STK tape drives

Tom Jameson
Advisor

Fiber connected STK tape drives

This is a duplicate post from the sysadm forum. The original post is at http://forums.itrc.hp.com/cm/QuestionAnswer/1,,0x2c1f5fe8b250d71190080090279cd0f9,00.html

We've run into a problem that has so far stumped HP, Storagetek and Veritas.

We have an rp7410 running 11i connected through our SAN fabric (EMC Connectrix/McData switches) to Storagetek 9840B and 9940B fiber tape drives.

The rp7410 has the latest and greatest patches (including PHKL_28217 SCSI tape cumulative). All the pieces are on EMC's certified list.

The HP can see the drives, they show up in ioscan and devices are created for each one. However, it cannot access the drives - mt, tar, dd all fail with a "cannot open". The one exception is that mt "status" command returns but cannot detect when the drive has a tape inside.

Also, since this has occurred, our copper connected DDS4 has gone brain dead with the same errors (no such device or address).

We are currently accessing some of the same drives with our old Sun system and it's working just fine (same fabric). The drive I'm working with on the HP is not zoned to any other system and has a tape in the drive. Any attempt to access it (mt "status" command, tar, dd, etc) results in either "can not open" or "no such device or address".

Any ideas are greatly appreciated.
2 REPLIES
Michael Steele_2
Honored Contributor

Re: Fiber connected STK tape drives

Basic rule of very old thumb with peripherals, bring them up first. So do this:

Stop the power on both server and tape library then bring up the tape library until it finishes initializing, and then power up the server.

I know its contrary to fiber since fiber is only seen at run level three but its worked for me before in similar situations.
Support Fatherhood - Stop Family Law
Tom Jameson
Advisor

Re: Fiber connected STK tape drives

We've tried powering the drives up first, power cycling them, even changing their drive emulation.

No luck yet.

Thanks,
Tom