StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

HDD shows 0 Mb total Mbytes

Jason Kho
Occasional Visitor

HDD shows 0 Mb total Mbytes


I have a problem with one of the HDDs on my system.

When it was in its original slot (0/0/2/0.2.0) "ioscan -fnkC disk" was showing that it was in 'NO_HW' state. After shutting down the system, resitting the HDD, and booting up the system, the ioscan showed the state as 'CLAIMED', but after awhile, another ioscan command show the state being back to 'NO_HW'.

After this, I shut down the system, removed the HDD and inserted it into another slot (0/0/1/1.0.0). This time ioscan shows that the HDD is claimed (even after a long while). But running SAM > Disks and File Systems > Disk Devices, the HDD shows 0 Total Mbytes. I have also tried doing a "diskinfo" on the HDD and got the following output 'diskinfo: can't open /dev/dsk/c1t0d0: Device busy.'

I suspect HDD failure, but would just like a second (or even third) opinion.

Thanks =)
Honored Contributor

Re: HDD shows 0 Mb total Mbytes

Hi Jason,

Look for errors in /var/adm/syslog/syslog.log.

As you have tried the hard disk in a different slot, the most likely chances (99%) are a disk failure.

practice makes a man perfect!!!
Andrew Rutter
Honored Contributor

Re: HDD shows 0 Mb total Mbytes

hi jason,

yes you are right it is faulty by the what you have said.
it should show the correct size and if diskinfo cannot comunicate witht he disk controller you will get an error similar to yours, unless its mounted still and active.

do you have STM online diags installed?

try and do a read test in that, if you have to verify. you can do this as a non destructive test. This should tell you about the disk also