StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

HP LTO3 drives "locking up"

 
New Member

HP LTO3 drives "locking up"

Hi,

I tried it several times on different mailing lists, I really hope you can help me with this problem.

I have 3 Overland NEO-2000 Libraries, one of them, the only one containing LTO3-drives is making problems. Every day the LTO3 drive(s) stop to work. First I thought it must be a hardware-problem, but after replacing every piece of hardware (HBA???s, The Server itself, the NEO2000-chassis, the cables, the drives, Library-controller-card and the Fibre-channel conversion card) I don???t know what it can be.

I switched different kernel versions, compiled the module directly from qlogic for my HBA???s ??? nothing helps. The support of the Library says it must be a software-problem, EMC says it must be a problem of the operating-system or of the hardware *grrrrr*

I???ve switched the scsi_logging_level to:

Current scsi logging level:
dev.scsi.logging_level = 691442237
SCSI_LOG_ERROR=5
SCSI_LOG_TIMEOUT=7
SCSI_LOG_SCAN=0
SCSI_LOG_MLQUEUE=1
SCSI_LOG_MLCOMPLETE=1
SCSI_LOG_LLQUEUE=5
SCSI_LOG_LLCOMPLETE=5
SCSI_LOG_HLQUEUE=1
SCSI_LOG_HLCOMPLETE=1
SCSI_LOG_IOCTL=5


It would be very nice if you see through the attached log (I cut it down to the time when the problem appeared) and give me some hints what could be the problem. I saw some things with timeouts, and timeleft=0. The problem is, at the moment I have no idea what exactly happens, I only know that for some reason the scsi subsystem tries to reset the device and after that it resets the HBA. I think this things are some error recovery routines. After it checks that the device is unreachable (and that the error recovery mechanism has not worked) it put the device offline.

What I???m interested in is, why does the problem appear, what is the initial problem to trace it down and hopefully can solve it.

I really hope you have time to help me,

Many thanks, Florian