StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

HP MSL5030 tape library drive Problem

GNOM
Frequent Advisor

HP MSL5030 tape library drive Problem

Hi,

I use an HP MSL5030 tape library with HP data protector for backup. The Library have 2 drives. Drvie 2 don't work correctelly since 2 weeks. The system don't report any problem but the drive can't unload medium after a backup or during medium formating. I cleaned the drive , but there is no change.
Here is the output of the data protector error during a backup :
Major] From: BMA@backupco "HP:Ultrium 1-SCSI_2_backupco" Time: Mercredi 31 août 2005 16:41:20
[90:180] Cannot rewind medium. ([5] I/O error)

[Major] From: BMA@backupco "HP:Ultrium 1-SCSI_2_backupco" Time: Mercredi 31 août 2005 16:41:36
[90:64] Cannot unload exchanger medium (Details unknown.)


5 REPLIES
Kurt Beyers.
Honored Contributor

Re: HP MSL5030 tape library drive Problem

Make sure that:

The windows drivers for the tape drive and robot arm are disabled in the Windows device manager
The Removable Storage Medium service is disabled too
The Fibre Array Monitor agent is disabled in the HP Insight Management Agents.

best regards,
Kurt
Marino Meloni_1
Honored Contributor

Re: HP MSL5030 tape library drive Problem

Yes looks like reservation conflict to me, but caused by a communication error.
Is the unit in SAN? if yes I would have a look at the switch logs and see if there is communication errors or crc errors growing.
NSR traces and logs can also give some input
If the libraty is scsi direct attached to the server, the system event log (in case of windows platform) should contain some errors that can give a hint

marino
Stuart Whitby
Trusted Contributor

Re: HP MSL5030 tape library drive Problem

Hmm, wierd one.

First question: how do you manage to clean the drive if the tape can't be ejected? If it's manually by pressing the eject button on the front, then it's possibly a damaged SCSI cable or faulty firmware on the drive which are causing rewind requests to be ignored (firmware is more likely - SCSI cable is likely to hit every operation, but backup/formatting appears to succeed).

Can you rewind this manually? Even if this is Windows, you should still be able to get mt tools to allow you to do commands like
mt -f rewoff
to rewind and offline it.

If so, it may simply be taking a while to prepare the tape for eject, but this really appears to be some other problem given the I/O error on rewind. Not sure where in DP, but there's likely to be a parameter which will allow the tape drive more time before an eject is tried (eject_sleep/unload_sleep in Legato NetWorker).
A sysadmin should never cross his fingers in the hope commands will work. Makes for a lot of mistakes while typing.
GNOM
Frequent Advisor

Re: HP MSL5030 tape library drive Problem

The Library is directely connected to the backup server with SCSII cables. The drive can scan mediums, and cleaned without errors. Errors occurs when formating and backup operations .

Thanks
David Ruska
Honored Contributor

Re: HP MSL5030 tape library drive Problem

Install library & tape tools (www.hp.com/support/tapetools), and collect a support ticket for the drive. We can look at the drive fault logs to see if it is reporting any errors on the unload.

You can also run the the LTO drive assessment test within LTT to check out the functionality of the drive.
The journey IS the reward.