StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Intermittent slow backups on DLT-8000

Paul te Bokkel
Occasional Visitor

Intermittent slow backups on DLT-8000

Hi all,

For a few weeks now we noticed one of our streamers falling behind from time to time.
When backing up some boxes (20+ and 50+ GB) sometimes the throughput with Arcserve 2000 dropped from 350 MB/min to 20-30 MB/min.

Ok.. faced with this, we installed AS2k SP4 on Win2k SP4, checked firmware (HP818 library and streamer were both up to date), checked cabling, switched SCSI-drivers from MS to AHA, tried AS9 client agents, all kinds of different client-settings, debugged our switches, observed interaction with other DLT-server; nothing.
It appeared to be only the streamer causing our headaches.

I must confess (but hey, it's not my fault ;) this streamer was running with AS periodic cleaning (every 50 hours or so). It's now switched off, but out tape-failures have been increasing the last two, three months. However, during tests with LTT I noticed that the same tape on two consecutive tests performed normal _and_ slow.

One time LTT gave a couple (6) of FIFO(SDRAM) CRC errors, but since then I have not been able to get the same results. The first time LTT was used, a 'logging high error rate' was logged (950 corrected write errors, 0 on read). A few hours later I encountered 61 corrected read errors and 302 corrected write errors, 2xA400, 3xA401 and 5xA404/5 errors in the last 120 hours.

Last remark: just now the LTT Connectivity Test failed (Data miscomparison: offset 20, expected 165, found 0).

Attached is a support ticket.


Currently I'm a bit at loss, but.. could it be a defective (HVD-) cable? Or head worn out? Anyone?

Regards,

Paul
4 REPLIES
Vincent Farrugia
Honored Contributor

Re: Intermittent slow backups on DLT-8000

Hello,

My guess is a worn head. That drive should never had underwent cleaning every 50 hours... cleaning too much ruins the head. A DLT8000 drive should only be cleaned when it tells you so (solid amber cleaning LED).

HTH,
Vince
Tape Drives RULE!!!
Curtis Ballard
Honored Contributor

Re: Intermittent slow backups on DLT-8000

As Vincent indicated, the most likely problem is a worn head. Worn heads are much more succeptible to large variations in performance with different tapes or even the same tape on different loads if the dust on the head moves around.

DLT drives are only rated at about 100 head clean operations so if you had periodic cleaning set at 50 hours that would mean 5000 hours of life and your drive has almost 14,000 hours on it.

The errors in the drive logs are also consistent with a worn head.

The best hope for DLT drives with worn heads is to try to find tapes that still work well with the worn heads. Some tapes will fit the wear pattern better and might still work well while others will have problems.
Jeffrey Willemsen
Frequent Advisor

Re: Intermittent slow backups on DLT-8000

FIFO(SDRAM) CRC errors are a known issue for a batch of DLT8000 drives that have defective memory chips. The problem with this is that all data you backup gets corrupted on tape without the drive (and you!) knowing about it. That would make a restore impossible. It is a known issue for a very small number of drives for wich a replacement procedure was (and maybe still is) available. Newer firmware will report a hardware error (sense code 04) if the situation occurs again. Because of the data corruption the drive will rewrite the data (if it detects it) which will slow the process down. Only option is: replace the drive, check for replacement procedure at HP or Quantum, there was a recall of these drives. Don't use that drive for critical backup again.

Jeffrey
Don't change a working configuration
Curtis Ballard
Honored Contributor

Re: Intermittent slow backups on DLT-8000

Jeffrey brought up the issue of a potential SDRAM failure which should be considered. As he indicates there were a few drives that have had SDRAM failures and had to be replaced.

The support ticket however shows that the drive is running V59 firmware. Firmware revision V59 will test for that condition and will fail the drive. Usually the drive will fail the power up self test. The drive logs are full of problems that are consistent with a worn head but there are no SDRAM error entries. The logs only cover the last 500 power on hours but that should be long enough if there is a SDRAM problem.

If you get this error code again pull a support ticket immediately and post it here. I can check and see if the drive has an SDRAM failure or if the error is due to difficulty reading.