StoreEver Tape Storage

Re: LTO3 drive ejecting all tapes with "Tape Error" LED

Go to solution
Occasional Advisor

LTO3 drive ejecting all tapes with "Tape Error" LED

Hi all,

I'm new to using tapes for backups and so I bought a second hand HP LTO3 drive to have a play and see if I can learn something.

Unfortunately none of the LTO3 tapes I have work with this drive.  Any tape I put in makes a few clicking noises then gets ejected with the Tape Error LED flashing.

I have tried two HP LTO3 tapes, two Sony LTO3 and even an IBM LTO1 tape but they all get ejected (although the LTO1 tape doesn't cause the Tape Error LED to start blinking.)

Apparently there is a "HP Tape Tools" program that is able to provide more information about issues like this, but the only place I can find to download it is the HPE website which says I need a support contract in place which obviously I don't have as I'm just doing this for my own education.

Does anyone have any idea what the problem could be with the drive?

lsscsi says it's "[9:0:3:0] tape HP Ultrium 3-SCSI G53S /dev/st0".  There's about a million model numbers and part numbers on the label so I'm not sure which one is relevant (or even why there are so many) but one of them is the "regulatory model" which is "BRSLA-0401-DC".

If there's anything I can test please let me know.  Thanks!

Occasional Advisor

Re: LTO3 drive ejecting all tapes with "Tape Error" LED

Well I found a Reddit post that included download links for the HP Tape Tools, so I tried v4.21 and v4.22 for Windows.

Both these versions detect the drive, but hard lock the machine as soon as I try to do anything with the drive.  The keyboard and mouse stop responding, and if I reset the machine, the drive is no longer detected (doesn't show up in the BIOS scan or Windows device manager.)  I have to power cycle the drive to get it to show up again, but every time I try to click on it in the HP Tape Tools, the machine locks dead.

I tried installing ASPI support and using that, but that just makes the program crash when it tries to scan the SCSI bus.

I looked at the Linux version but it looks like it's not actually a Linux version, as it only contains a Red Hat .rpm file which doesn't work on the distro I am using on the machine.  It also looks like it needs Java installed so presumably it needs a GUI, but I don't have one installed in Linux as it's normally a headless server.

Does anyone know what to do next when the HP Tape Tools locks up your machine?

Trusted Contributor

Re: LTO3 drive ejecting all tapes with "Tape Error" LED


by the sound of it you have a major hardware problem especially if the tape isnt loading onto the spool.

sometimes when using ltt, you click on the drive and it can take along time to read from the drive.


Occasional Advisor

Re: LTO3 drive ejecting all tapes with "Tape Error" LED

Well after more trial and error I tried a different SCSI card and that fixed the lockup problem - the LSI Logic card's Windows drivers seem quite buggy (the card works fine under Linux), however replacing it with an old Adaptec 40MB/sec card did the trick and I was able to access the drive without the machine locking up.

The drive logs did indeed say the head was misaligned, although I was able to run the drive self-assessment test and after a few louder than normal clunks, this actually "fixed" the drive and it will now accept tapes again.

The assessment keeps coming back saying something like the head is wandering though, which results in decreased performance and they recommend the drive should no longer be used.  But since this is just for a hobby and learning about tapes, I think it will do the trick.

I just wish the Tape Tools software was a bit easier to get hold of, it would have saved a lot of hassle!