StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

Low Performance Ultrium 230 on W2K

Wilder Mellotto
Frequent Advisor

Low Performance Ultrium 230 on W2K

I have a low performance in backup with a Ultrium 230e : 2MB/s

I run Omniback 4.1 on W2K
My client is Unix running Informix
My network is Gigabit, no Lan problem for backup.

I read some problems here, and make the changes:

Disable Tape Drivers in Hardware Profiles, with this Omniback can see de device:

Change the Advanced Settings in Omniback:
Block Size : 256k
Seg. Size: 512
Disk. Ag. Buffers: 32

Add a key in my registry:
REG_DWORD = 67 (hexa)

Change the host adapter:
Transfer Rate: 80

I don???t found anything else to improve performance on my backup. Please, verify if I make the correct changes.
Leif Halvarsson_2
Honored Contributor

Re: Low Performance Ultrium 230 on W2K

I have done a lot of performance testing with Ultrium drives and OmniBack 4.x both with NT/W2000 and HP-UX.

At first, the 2MB/s is far to low, it was hard for me to reach the same performance with NT/W2000 as with HP-UX but at least 15-20MB/s was no problem (the HP-UX box streamed with full 30MB/s).

I dont recommend to change the settings before you can get resonable performance with defaults. There is some cautions in the release notes here. I have done some tests with bigger block and segments but did not notice much difference (if any).

There can be many possibilitys for bottlenecks, some ideas:

Try a local filesystem backup to the Ultrium drive, use rather big files 1MB or more and as much data you can get a reliable result.

Monitor the cpu load on the Cell server and cpu and disk load on the client during backup.

Try transfering data with ftp to test it is not some strange network problem.
Wilder Mellotto
Frequent Advisor

Re: Low Performance Ultrium 230 on W2K

I have files with 1.5 Gb and still the same 2Mb/s.

My system dont't overload cpu or memory when i start a backup.

With many contacts, I discovered that he can be hardware problems, controller scsi or the LTO Ultrium.

My controller is a Adaptec SCSI Card 29160 Ultra 160 SCSI, and I'll see a new controller. Do you have any good idea?

Vincent Farrugia
Honored Contributor

Re: Low Performance Ultrium 230 on W2K


Go to this link:

If the drive is attached on the Win2K machine, install the driver for it. The Ultrium should be quite happy on your Ultra 3 card. On that site, there are drivers for Adaptec SCSI cards as well. You might yours included, not sure.

Tape Drives RULE!!!
Wilder Mellotto
Frequent Advisor

Re: Low Performance Ultrium 230 on W2K

I have installed all new drivers to adaptec scsi controller and the LTO Ultrium, and the last Firmware.

In a server Risc, runnig HP-UX 11.01 I have a LTO making local and network backup, with this:
15Mb/s - local
12Mb/s - network

I don't have a chance to test the LTO with performance problem in this Risc server, but I still believe that I have a hardware problem, and not a driver or configuration.
Kevin Longley
Occasional Visitor

Re: Low Performance Ultrium 230 on W2K

I have the identical problem. Were you able to solve it?
Andy Buckley
Occasional Visitor

Re: Low Performance Ultrium 230 on W2K

My name is Andy Buckley and I work at HP Bristol, where Ultrium technology is developed.

I suggest a structured approach
1. Use the pat tool attached to determine how fast your hpux box can read the files being used in the backup to the W2K with OBII.
This is a script type pat -h for usage info.

2. Use a tool like ttcp available from cisco site to checkout your Gigabit LAN performance.

3. On the W2K box on startup look at the BIOS screen for the Ultrium drive connected to the 29160, make sure the negotiated speed is displayed as 80MB/sec. There was a problem with the 29160 drivers about 12 months ago the Adpatec driver ran slow but the one embedded in W2K was OK. The latest driver from adaptec corrects this bug.

Olaf Gajewski
Occasional Visitor

Re: Low Performance Ultrium 230 on W2K


I've seen a similar problem when I started testing performance in my environment (LP2000r with Ultrium 215 attached to a Adaptec 29160).

I found an article describing performance issues:

This one suggested not to take the adpu160m.sys with version 6.0.4000.200, but to take the older driver 6.0.4000.100.

I've had a similar problem to yours when running it with the .200 driver. When running it with the .100 version driver performance increased.

Also see:*&p_li=

Wilder Mellotto
Frequent Advisor

Re: Low Performance Ultrium 230 on W2K


Andy Buckley, thanks for your response.

My problem with performance is solutioned, finally. I make some additional tests in other equipments. When I came back to the first equipment, the free slot for SCSI adapter doesn't the same standard.

SOLUTION: change another board to an PCI slot, and put the SCSI 29160 in the correct slot.

This solved the performance problem, going to 20 mb/s

Thanks a lot for all...
Declan Hogan
Frequent Advisor

Re: Low Performance Ultrium 230 on W2K

I had similar problems with our Ultrium and after exhaustive testing I found the problems were mainly caused by the fact that IP/Sec was running on the W"K Servers. When we disabled (for backup only) IP/Sec we had a very big improvement in performance. I see you are backing up a Unix machine to W2K Cell Manager, we have an all NT / W2K setup, however we have systems in 2 different domains and I experienced very poor performance when backing up a Server in one domain to a tape device in the other.
It appears the problems were caused by going across domains. When I changed the backup to store to device in the local domain performance was as expected.

Hope this helps.

Declan Hogan.
Declan Hogan