StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

MSL 6030 (AD608A) firmware upgrade

Mikel_7
Occasional Advisor

MSL 6030 (AD608A) firmware upgrade

Hi all,
I have to upgrade firmware of MSL6030 library to 5.16 version.
It has a problem and Web interface of it is not functioning so I have to upgrade using serial interface.
I connect the PC to serial interface and from Hyperterminal I see:
HP Network Storage Router. (I have attached the picture).
How can I upgrade the firmware of MSL from here?
There is not any other serial connection in MSL.

Thank you
Mikel
5 REPLIES
David Ruska
Honored Contributor

Re: MSL 6030 (AD608A) firmware upgrade

You are attached to the serial interface of the NSR (FC) router, and not the MSL. No, you cannot update firmware of the library through the NSR.

Rather than using a serial interface, I would recommmend using HP Library & Tape Tools on your host. That is the recommended way to update library and drive firmware. See www.hp.com/support/tapetools to download the tool.
The journey IS the reward.
Mikel_7
Occasional Advisor

Re: MSL 6030 (AD608A) firmware upgrade

Hi David,
Thank you for the response.
I tried to update firmware through HL&TT but I cannot reach the library, as it is not initialized and HL&TT does not recognize it.
The library has a problem with the shuttle, it jams at the last tape and returns 3013 error. I see that there are some fixes in the 5.16 firmware release:


Fixes in this release:

1. Issue where some units were getting randomly getting FSC 3013 Drive Fetch failure errors.

So I want to upgrade the firmware.
Exist there any way to attach a serial interface to the library?
Please help me how can I reach MSL through HL&TT.

Thank you
Mikel
Mark Poeschl_2
Honored Contributor

Re: MSL 6030 (AD608A) firmware upgrade

What exactly do you mean by "not initialized". Is the library failing on its POST? Are you able to access all the front panel screens?

The fact that you were getting tape jams implies that at least one system was able to use the library and its drives. That system is where you need to install LTT. LTT does not require a network connection to the library, but rather uses the FC connection.

FYI - the firmware in your NSR is also one rev behind. The latest is 5.6.87.
Mikel_7
Occasional Advisor

Re: MSL 6030 (AD608A) firmware upgrade

Hello Mark,
Yes, I am not able to access front panel, because the robot arm hangs on moving, in LCD panel is displayed an error and the library cannot initialize.
What I am planning is to order a new part and after to upgrade FW.
Coul you suggest any other thing?

Thank you
Mark Poeschl_2
Honored Contributor

Re: MSL 6030 (AD608A) firmware upgrade

Nope - getting the hardware fixed so that is passes POST is the obvious first step. After that install LTT on the server that's going to use the library and upgrade both the NSR and library firmware. Note that you may also need to upgrade tape drive firmware.