Email Subscription Notifications Suspended Temporarily
We are in the process of making navigation in the Servers and Operating Systems forums simpler and more direct. While doing this, we have to temporarily suspend email notifications for subscriptions. If you are subscribed to one or more discussion boards or blogs in the community, please check them daily to see new content. Notifications will be turned back on in a few days. We apologize for any inconvenience this may cause. Thanks, Warren_Admin
StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

MSL5026 firmware update not working

Jimmy O'Brien_1
Occasional Contributor

MSL5026 firmware update not working

I am trying to upgrade firmware on my MSL5026. Currently the firmware version is 2.33.

I have attempted to upgrade through LT&T and its is not possible.

I cannot upgrade from MSLUTIL since I dont have RS232 cable

Finally i am attempting to upgrade from the Web Interface. I can get the file uploaded onto the library. I then attempt the flash operation only to get the following error "The "Flash Library from Local File" operation failed: Error= F001"

Any ideas folks

David Ruska
Honored Contributor

Re: MSL5026 firmware update not working

Let's try diagnosing the L&TT firmware update issue first.

Can you explain why it was not possible?

Which file you use for the web interface flash? The error F001 (Bad Image CRC) means "The uploaded firmware image has a bad CRC and is probably corrupted".

I assume you tried to use the LTT (.frm) image. For the web interface, a .bin image is used.
The journey IS the reward.
Honored Contributor

Re: MSL5026 firmware update not working

HI Jimmy,

The LTT method is the convenient one. If you placed the firmware file in the proper directory, the utility will indicate to you about the update option available.

You should definitely persue that option. Let us know what is the problem in LTT firmware update.

With regards,
Attitude, Not aptitude, determines your altitude
David Ruska
Honored Contributor

Re: MSL5026 firmware update not working


We did some testing on this, as 2.33 firmware is really old (about 6 revs back from the current 5.07 release).

The MSL firmware changed how the read element status worked with revision 4.08 and above, and this caused issues with LTT associating the drive to the library. LTT was updated with version 3.1 SR1, but the change did not allow it to also work with the older library code.

You could use an older version of LTT (3.1 or earlier), but it's no longer on the external web via an ftp link.

For your case, the easiest solution may be to use the RMI (web interface) with the proper file (non LTT). Here's some instructions:

Ftp the NextGen_507.bin file to the "upload" directory on the library and then use the RMI to flash the library from local file.

The BIN file can be manually downloaded from the HP Support web (under the "Cross operating system (BIOS, Firmware, Diagnostics, etc.)" heading) or directly from the ftp location that newer library firmware can access for remote firmware flash through the RMI.

Let me know if this resolves your issue.

HP Engineering
The journey IS the reward.
Jimmy O'Brien_1
Occasional Contributor

Re: MSL5026 firmware update not working


That worked a wonder. i was using the wrong file with the web interface, when i downloaded the correct file it worked first time.

I also loaded LT&T and that works now

So all in All a great result.

Many thanks