StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

MSL6030 High Polling Rate

Jen Pineau
Occasional Visitor

MSL6030 High Polling Rate

I have a new MSL6030 library with 2 Ultrium 960 drives using a U320 dual port SCSI HBA, and I keep having issues with it.

In the middle of a tape erase or inventory, it will loose connection with the library, and I'll have to reboot the library to get it going again.

I occasionally also get this error:
Fault Code: 3011 (IPO)
Description: Bin Fetch Failure

When I run LTT v4.51, it runs a library read/write test just fine, but when I tell it to do a device analysis, it shows this for both drives:
"There are indications that the drive is experiencing a high polling rate on the SCSI Interface."

I am using the default configuration values on the library and the scsi card. Are there any values that I should be changing on either the library configuration or the SCSI card configuration?

I've already had one of the drives replaced, and I'm still having these issues.

I am running Windows Server 2003 R2 SP2 32-bit (tried 64-bit already and had too many problems with drivers, so I went back to 32-bit)

LTT support file attached.

Thanks.
5 REPLIES
TapeDrive Killer
Trusted Contributor

Re: MSL6030 High Polling Rate

Hi Jen

You should have 1 terminator located on each Tape Drive NONE on the library controller.

About the error 3011 it happens because the shuttle has a problem and cannot grab the tape cartridge please open the library and see that, here is a link for troubleshooting.
http://tinyurl.com/6n878s

High pulling its a common problem with LTO drives bassically what happen is that RSM (removable Storage service) send TUR (test unit ready) commands to the drive so the backup job can failed because of this.
http://support.microsoft.com/kb/842411

First you need to go on device manager and look for the media changer and tape drives then right click properties, driver and Driver detailsfor media changer and tape drive.

you will get for example C:\WINNT\system32\DRIVERS\dlttape.sys so you need to write down dlttape because you need that later.

Then go to registry editor on regedit and look for the driver on
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
*If you use VERITAS backup software you will see something like dlttapeVRTS or halfinchVRTS.
then when you are there right click and make a new Dword value and write AutoRun=0 its case sensitive.
That command will stop RSM to send TUR commands you will need to do this on the medium changer driver as well.

Reboot you server go to services, set RSM to manuall start it , stop it and set it to dissable then stop all your backup software services and perfor the anailsys test on LTT

Regards

Pablo Alvarado
Tape Storage DPX

One drink away from sleeping on the pavement

Re: MSL6030 High Polling Rate

I still kept the problems even after I have done all the "tweaks" to the Windows system, which has become a standard for every Windows installation I do.

Even a LTT r/w test of 30GB gave the same high polling rate message.

So, I started another test, this time with the HP Insight Storage Agent service stopped.
This time they all passed !
I reconfigured the HP Management Agents and disabled the SCSI Information agent.
Test ran fine again.

I usually don't have to disable anything within the HP Management agents, but obviously something has changed (again) with PSP800 for Windows.

Anyone with the same experience ?

regards,

Martijn



MUKUL BANERJEE
Occasional Advisor

Re: MSL6030 High Polling Rate

Hi Jen,

One of the possible solutions can be disabling the Polling from Windows registry..

1. Install the 1.0.4.0 or later driver.

2. Disable device polling in the system registry by completing one of the two steps below:

The driver package contains a DisableAutoRun.reg file that can used to modify the system registry and disable RSM polling. Logged into the system as a user with Administrative privileges, double-click on the DisableAutoRun.reg file. The system will prompt by asking â Are you sure you want to add the information in c:\tmp\DisableAutoRun.reg to the registry? (path information will vary depending on where the .reg file is stored). Responding â Y�? or â Yes�? will modify the appropriate registry entry to disable polling.

OR

Manually edit the system registry using RegEdit. Logged into the system as a user with Administrative privileges, run RegEdit and navigate to the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\hplto.

To disable RSM polling, edit the AutoRun value found in this key. A value of 0 (zero) indicates that polling is disabled; a value of 1 indicates that polling is enabled.

After completion of these steps, the affected system should be rebooted

IMPORTANT: Adding or removing tape drives from the system may cause an older driver inf file to be re-read, which in turn can re-enable RSM polling. If drives are added or removed, the registry should be checked for proper configuration and, if necessary, repeat step 2 above.


The solution is as per customer adviosry http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c00718488 , this can be tried with the standalone Ultrium tape drive or MSL.

Regards,
Jen Pineau
Occasional Visitor

Re: MSL6030 High Polling Rate

I ended up having the whole chassis replaced (everything except the drives) due to the 3011 error, which turned out to be the robotic arm was not able to pick up tapes in certain slots.

After the chassis was replaced, I've never gotten any more High Polling Rate errors... So I think I just had a bad unit out of the box. Everything's finally working great now!
Marino Meloni_1
Honored Contributor

Re: MSL6030 High Polling Rate