Email Subscription Notifications Suspended Temporarily
We are in the process of making navigation in the Servers and Operating Systems forums simpler and more direct. While doing this, we have to temporarily suspend email notifications for subscriptions. If you are subscribed to one or more discussion boards or blogs in the community, please check them daily to see new content. Notifications will be turned back on in a few days. We apologize for any inconvenience this may cause. Thanks, Warren_Admin
StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

MSL6030: LTO2 drive failed after firmware upgrade

Paulo Mira
Occasional Contributor

MSL6030: LTO2 drive failed after firmware upgrade

Hello,

I'm having a problem with one of our LTO2 drives.

MSL6030 with 2 Ultrium2 drives + NSR E1200.

I downloaded the latest version of LTT, plus the latest firmwares, and proceeded to update
the library and drives. We've been upgrading firmwares in our SAN, and only the library had
outdated firmware.

I tried to go to FW version 0520 for the MSL, and F68W for the drives.

The firmware upgrades went well for both the library and the 1st drive, but the second drive
failed. After that, the drive was marked as "missing" from the MSL, and it didn't show up on the NSR's SCSI bus. I Rebooted the library, but to no avail. After some time, and a few reboots later, i managed to communicate with the drive: it was showing problems, such as not having a serial number, but i did manage to pull out a LTT support ticket, which i am attaching.

I tried using LTT to re-flash the drive's firmware, but it didn't work.

Trying to re-flash the drive, without going through LTT / Windows / FC would be my next step, but i've been searching HP's site for a version of the firmware which i can use with the MSL's ftp / web update facility, and i haven't been able to find any.

This drive has barelly been used, so i'm a little reluctant to call HP Support, because they will probably swap this drive for another one which might not be in such a good shape.

I would apreciate your input on this issue, specifically, i'd like to know if you think it's a good idea to try to re-flash the drive. Also, to do so, i will need the correct firmware, and instructions on how to do the ftp flash (will i need a password?)

update: i tried to use LTT to get a support ticket for the whole MSL, but i was once again unable to communicate with the faulty drive. I did get the ticket, but with no info regarding that drive. So i am attaching two support tickets, one for the faulty drive (st_20070225_001213.lzt) and one for
the whole MSL, but without info on that drive (st_20070227_194350_3G42LRP6CE.lzt)

Thanks in advance for all the help you can spare.
7 REPLIES
Torsten.
Acclaimed Contributor

Re: MSL6030: LTO2 drive failed after firmware upgrade

Hi,

in the support ticket your "faulty" drive is complaining about a needed power cycle.

Try to power cycle the library and check again.

But if your drive is really damaged there is nothing you can do...

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Marino Meloni_1
Honored Contributor

Re: MSL6030: LTO2 drive failed after firmware upgrade

Yes the drive ask for a power cycle. then shut down the library and remove power for at least two minutes.

if this do not clear the problem, then the other info in the log: "Rule Description : EEPROM calibration errors" can be the cause of the problem. I suggest you then to try again to flash the drive firmware, using LTT via SAN, but be sure to stop any backup activity, and be sure there is no polling from other host, like TUR from W2k3 server, or insigh agent polling drives.
if you are not sure, you can try to connect the drive directly to a scsi HBA in a pc or a server, and flash the firmware directly from there.
If the procedure do not recover, you can ask to replace the drive at HP, without any reluctancy because the drives that are used for replacement are like new one.

marino
Paulo Mira
Occasional Contributor

Re: MSL6030: LTO2 drive failed after firmware upgrade

I had already power-cycles the library, but i did it again, just in case. All is the same as before.
I tried to re-flash the firmware, using ltt, but with no success, immediately after the process starts, it ends with a Firmware update FAILED! message.
This drive is reported as being at F68W (latest) firmware level. If i try to re-flash it with an older firmware, the exact same thing happens.
I know that i would have to use a factory password to flash a drive with an older firmware than the one it is currently at. Is is possible that the same applies to re-flashing the drive with the same firmware it is currently at?
Marino Meloni_1
Honored Contributor

Re: MSL6030: LTO2 drive failed after firmware upgrade

no, you do not need a factory password to reflash with same FW version.
if you want to try downgrade the FW, you can call hp and ask for a temporary factory password, this allow you to downgrade the fw for testing prurpose
MSECO_1
Trusted Contributor

Re: MSL6030: LTO2 drive failed after firmware upgrade

Temporary password is '3A9NSH93FAYEFS'
Password valid 20 days from 02/28/2007
(Remove ('') for password use)

Attached is the previous firmware for your tape drive LTO2, version: F59W

Try with this one
Keep learning!!!
Paulo Mira
Occasional Contributor

Re: MSL6030: LTO2 drive failed after firmware upgrade

Even with the factory password, i was not able to re-flash the drive, either with the latest firmware, or an older one.
I have called HP Support, who replaced the drive.
All is fine, now, drive shows 100% life remaining.

Thanks to all that helped, points assigned.
Mike Cross
Advisor

Re: MSL6030: LTO2 drive failed after firmware upgrade

Sounds like something happened to the drive during the upgrade process. Either a reset or someone power cycled the library. In any
case it sounds like the flash has been corrupted and you will need to replace the drive.