StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with SAN attached MSL6030 and FC2101 fibre cards

GilchristT
Advisor

Problem with SAN attached MSL6030 and FC2101 fibre cards

Hi

I'm crossposting this to the SAN and tape groups as it's a mixture of both. I've a new MSL6030 with 2 * LTO-3 which I'm connecting into an existing SAN configuration.

The existing SAN infrastructure between hosts and library is a Storageworks 2/16 switch and FC2101 (Emulex LP952) cards. All are at the latest firmware 3.93a and v3.2.1 respectively.

My backup software, Commvault Galaxy 5.9 SP4, reports IO errors when connected through the SAN. It works fine if I patch a fibre lead directly from the server to the library.

I've replicated the error using Microsoft Backup.

If I replace the Emulex card with a QLogic one all works fine. The problem is I've four servers to connect and a single QLogic card.

The servers run a mixture of Windows 2000 and Windows 2003. All are fairly new Proliants.

All the components in question are on the HP EBS matrix. Anyone any thoughts?

thanks

tommy
5 REPLIES
Steven Clementi
Honored Contributor

Re: Problem with SAN attached MSL6030 and FC2101 fibre cards

Tommy:

How is your zoning set up? That is, do you have a single zone that had all 4 hosts and the library in it? or do you have a separate zone for each host?

I know it does not sound like a zoning issue, but I like to rule out the possibility of interaction between multiple emulex cards in a single zone when utilizing a Tape Device (vs. a Storage Device).

Maybe you can trade the emulex cards in for 4 new qlogic cards? or at the very least, get a nice credit for them? Talk to your vendor and/or HP.


Steven
Steven Clementi
HP Master ASE, Storage and Clustering
MCSE (NT 4.0, W2K, W2K3)
VCP (ESX2, Vi3, vSphere4, vSphere5)
RHCE
NPP3 (Nutanix Platform Professional)
GilchristT
Advisor

Re: Problem with SAN attached MSL6030 and FC2101 fibre cards

The zoning is setup as individual zones for each host / library link and seperate zones for host / disk storage links.

The Emulex cards are from a bunch the customer bought about two years ago so I don't think there's much chance of getting them replaced FOC - and I work for the vendor so I'm fairly sure about that :-(

I think replacing them is the way to go but I've got a downtime window for this weekend and the next one is months away. Can't get replacements here quickly enough.

tommy
Steven Clementi
Honored Contributor

Re: Problem with SAN attached MSL6030 and FC2101 fibre cards

Tommy:

Is the library, nsr and tape drive firmware up to date?

Latest builds are 516 (Library), 5687(NSR) and G25W(LTO) I believe.



Steven
Steven Clementi
HP Master ASE, Storage and Clustering
MCSE (NT 4.0, W2K, W2K3)
VCP (ESX2, Vi3, vSphere4, vSphere5)
RHCE
NPP3 (Nutanix Platform Professional)
GilchristT
Advisor

Re: Problem with SAN attached MSL6030 and FC2101 fibre cards

Steven

Got it sorted. I had already brought all the firmware revisions up to date but your switch configuration suggestions put me back on the right track.

Turned out it was a setting on the NSR. It had "Use Hard AL_PA" enabled. Set it to disabled and all went well.

Out of interest I reset the NSR to factory defaults and the default is disabled! Looks like I have a pre-loved unit here. I should have realised when the devices were presented to the servers as soon as I powered it up rather than needing mappings created.

Chalk yet another one up to experience. Thanks for the help.

tommy
Steven Clementi
Honored Contributor

Re: Problem with SAN attached MSL6030 and FC2101 fibre cards

Tommy:

Sometimes HP hardware comes out of HP testing and does not get "reset". It is not common, but I have had hardware come to me in a similar fashion. I had an eva once go to a customer in "debug" mode. That was a fun day!!


Steven
Steven Clementi
HP Master ASE, Storage and Clustering
MCSE (NT 4.0, W2K, W2K3)
VCP (ESX2, Vi3, vSphere4, vSphere5)
RHCE
NPP3 (Nutanix Platform Professional)