StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

Problems with DDS3 drive

Go to solution
Mark Lawley

Problems with DDS3 drive

We have been having a problem with an internal DDS3 drive in our D320 running 10.20 for a couple of weeks now.

We were using a DDS2 drive up until it failed two weeks ago and was replaced by an HP tech with a DDS3 drive. The new drive worked OK for a couple of days and then refused to eject tapes. HP insisted they had tested the drive and it was good.

The device files were deleted and we created new ones using /dev/rmt/1m etc. Again the drive worked OK for a couple of days and then failed again. This time on the advice of HP we disconnected the CD drive which is on the same SCSI bus. Once again the tape drive worked OK for a couple of days before failing. We are starting to think the tape drive is faulty but the HP tech insists there is nothing wrong with it.

Does anybody have any ideas what could be causing this?
Shannon Petry
Honored Contributor

Re: Problems with DDS3 drive

First, make sure that your completely patched for all hardware and drivers.

Second, what else is on the same bus as the tape drive?

Because of the speed of a DDS3/4 on older systems isolate them to their own bus. The issue could be a timeout issue on responses when I/O is bound.

Microsoft. When do you want a virus today?
doug mielke
Respected Contributor

Re: Problems with DDS3 drive

Since the drive seems to work delivering data, and the only problem seems to be ejecting the tape, I'd suspect a power problem.

I don't remember the guts of D classes, but if there is a shared power connection, I'd try to swap it with some other device.

Other 'weird' scsi problems seem to always be related to termination / cableing.

Michael Steele_2
Honored Contributor

Re: Problems with DDS3 drive

Its DOA. I'm surprised HP gave you grief about replacing it. Use these commands to obtain status and eject tapes:

mt -t /dev/rmt/0m status
mt -t /dev/rmt/0m offl
Support Fatherhood - Stop Family Law
Bill Hassell
Honored Contributor

Re: Problems with DDS3 drive

Definitely a hardware problem. HP may be pointing to your software but what happens when you push the eject button? If the tape doesn't pop out, ask HP to replace the drive. The DDS3 drive is a solid performer. Since you are using an obsolete version of HP-UX, you may want to download the last version of SupportPlus and update to the last set of patches, both software (now called QPK) and hardware (HWE).

Bill Hassell, sysadmin
Steven E. Protter
Exalted Contributor

Re: Problems with DDS3 drive

We went through the same upgrade on a D320 a few years back. No problems at all. The drive is bad or improperly installed. If they won't come out and fix it tell them Bill Hassell says to fix it.

Seriously, escalate to managers until you get satisfaction.

Steven E Protter
Owner of ISN Corporation