StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

SCSI or DLT drive pb ?

Occasional Contributor

SCSI or DLT drive pb ?


I have a problem with an hp9000 HPUX 11.00. since yesterday.

I'm using omniback and even if the backup are going fine, I can't restore anything (I/O error on /dev/rmt/0m).
So, I tried with several DLT tape and when I directly tar files, the process is going fine (No errors and everything seems to be written on the DLT). But if I try to read the DLT, I have the following error in my syslog :

vmunix: SCSI: Unexpected Disconnect -- lbolt: 597289, dev: cd043000, io_id: 4000f23

and I can't read anything. I find strange that the pb occurs only when I read DLT, not when I wrote on them. Do you think it's an SCSI pb or is the DLT drive KO ?

I rebooted the server and verified the cables but it didn't changed anything. :(
And the drive is alone on the SCSI link.

Txs for your help



P.S. This thread has been moved from General to Tape Libraries and Drives. - Hp Forum Moderator

Bernhard Mueller
Honored Contributor

Re: SCSI or DLT drive pb ?


if you can reproduce the problem and it always happens only when you read, not when you write to the tape, I would assume it has to be the drive. Especially since you say you verified the cable (and connectors and terminator I guess).

Michael Steele_2
Honored Contributor

Re: SCSI or DLT drive pb ?

Might be a bad tape. Does this happen for every tape?

a) The 'lbolt' is the number of clock ticks since the last boot.

b) What is the device, c4t3d0?
# ioscan -fnkC disk

c) Please attach LOGTOOL report:


d) You can increase the timeout and the queue depth:

pvchange -t 60 /dev/rdsk/c4t3d0

scsictl -m queue_depth /dev/rdsk/c4t3d0
Support Fatherhood - Stop Family Law
Elmar P. Kolkman
Honored Contributor

Re: SCSI or DLT drive pb ?

Have you tried using the tapedrive from the unix command prompt? For instance using commands like tar?
Every problem has at least one solution. Only some solutions are harder to find.
Occasional Contributor

Re: SCSI or DLT drive pb ?

OK, txs for your help.

It's always the same problem wathever the tape inside, and same pb occurs with tar.

I try the ioscan and so on monday and let you know the result.

Occasional Contributor

Re: SCSI or DLT drive pb ?

This is this device :
#ioscan -fnkC tape
Class I H/W Path Driver S/W State H/W Type Description
tape 0 0/3/0/0.3.0 stape CLAIMED DEVICE QUANTUM DLT8000
/dev/rmt/0m /dev/rmt/c4t3d0BEST
/dev/rmt/0mb /dev/rmt/c4t3d0BESTb
/dev/rmt/0mn /dev/rmt/c4t3d0BESTn
/dev/rmt/0mnb /dev/rmt/c4t3d0BESTnb

and here is the logtool file :
FrankJan Franken
Occasional Advisor

Re: SCSI or DLT drive pb ?

I've got the same problem once with a DDS tape drive. It turned out, the drive locked up the SCSI bus. Tape drive has been replaced, it was defective.