StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

StorageWorks 1/8 G2 LTO4 "SEEK"

StorageWorks 1/8 G2 LTO4 "SEEK"

Hello everybody, I have a strange problom with my new backup device..

OS: SuSE Linux Enterprise Server 10 sp3

Device: StorageWorks 1/8 G2 LTO4

Bus adapter: SC44Ge

Software: Data Protector Express 4 sp1

Firmware: All firmware updated


I scheduled a daily full backup, it worked for 2/3 weeks, one day i noted that the backup doesn't complete, error gived me by the data protector is no media found..i stopped the job and launched a backup manually.

from the status of the job i can see the backup job start to collect data, after it move the tape from tape from storage to drive, then i see the status in "Mounting" and the front LCD pannel of the autoloader "SEEK", and the backup job do not go ahead anymore, untill abount 1 hour, it turn me back a error saying "insert compatible media"


For troubleshooting i installed i windows 2003, same software..and backup works!!! why??? now i have i dual boot with windows 2003 and sles10 sp3, from windows side the backup works, and from sles side it doesn't..


Hardware problem? I contacted the hp support, and they repleaced the drive.

Software problem? But i worked for a couple of week..


can anyone help me?



Curtis Ballard
Honored Contributor

Re: StorageWorks 1/8 G2 LTO4 "SEEK"

As you appear to have surmised, this doesn't appear to be a hardware problem so chances are you will hit it again even if it is working now.  Logs from the tape drive would help to give a view into what is coming from the server so if it does happen again please use the library web interface and grab a support ticket from the drive as soon after the failure as possible and the SCSI command history may help us figure out what is going on.  You can also use HP's L&TT to grab the support tickets


The first thing I would recommend checking is to make certain that you have the right drivers from HP for your Linux system.

Re: StorageWorks 1/8 G2 LTO4 "SEEK"

Thank you Curtis for reply..

yes, if i'm not wrong, there's no driver about autoloader for linux, and i installed the driver of the HBA SC44Ge in my system..

I used also L&TT to perform tests, and all tests ended with success..

from the data protector interface, on the diagnostics tab of the drive, i can see as attached file


How can I get SCSI command history?




Curtis Ballard
Honored Contributor

Re: StorageWorks 1/8 G2 LTO4 "SEEK"

The SCSI command history from the drive is available in a "support ticket" which is a data set that the HP Library and Tape Tools utility (L&TT) mentioned in the first post can read.  That support ticket can be pulled from the drive using the library web interface or the L&TT utility can read it from the drive when run on a server with access to the drive.


The last SCSI command shown in your screenshot is an interesting one, rather odd but legal.  It is a "LOCATE" command with the destination of the locate specified as the beginning of tape (BOT).  Usually a rewind would be sent instead of a locate BOT command but either way the drive should position to the beginning of the tape.


The data in the error response is interesting.  It is a "UNIT ATTENTION" condition which is a SCSI response saying "something has changed".  In this case the drive is reporting that it has transitioned to READY from NOT READY and that media may have changed.  That usually means that the tape was ejected and reloaded.


Is there anything else running on your server that may be attempting to access the tape drive?  We have seen problems with some Linux configurations where some application attempts to query the tape drive status and ends up changing it.


Grab a support ticket and post it here following the error if you see it again and that will show not only the SCSI command history but whether the tape was unloaded/reloaded.  The unload/reload is a bit burried so we'll probably have to dig that out but you can view the SCSI command history if you want by setting the detail level in the ticket viewer to "Everything".

Re: StorageWorks 1/8 G2 LTO4 "SEEK"

Here is the support ticket grubed from the web interface of the this time, there is a erase job of all media running..when possible i will grub a support ticket while doing backup job



Curtis Ballard
Honored Contributor

Re: StorageWorks 1/8 G2 LTO4 "SEEK"

Thanks for the ticket.  It shows that the drive has been having problems locating a position on tapes NF4996L4 NF4998L4.  That would explain the long "SEEK" and eventual error.  Replacing a drive probably wouldn't make that problem go away as it is usually caused by an index error on the tape.


If you are able to reformat those tapes it may resolve the situation at least for now but we need to understand why the problem happened in the first place.  I'll look into the logs further and see if I can figure anything out.

Re: StorageWorks 1/8 G2 LTO4 "SEEK"

Thank you Curtis..yesterday I have also realized that the problem was on the tape, because drive go in SEEK also on windows not only on linux filesystem..I identified the bad 4 tapes and remove them, then i can do backup without problem..

And i was not able to erase or format the bad tapes with the DPX i used L&TT to perform i write&read test, after this the tapes are usable again..realy don't know what happend, beacuse tapes are brand new.


Thanks very much, let me know when you discover what caused those problem or if you need i grub a new ticket..

Super Advisor

Re: StorageWorks 1/8 G2 LTO4 "SEEK"

I have a StorageWorks 1/8 G2 but with LTO3.The same problem.

Somebody have the answer about why is necessary to run a test w/r with LTT to the 1/8 recognize the tapes and don't send the SEEK messages?

Occasional Advisor

Re: StorageWorks 1/8 G2 LTO4 "SEEK"

Do you performed a test with write option that erases the data?

I have the same problem, but i cannot erase tapes, because there is a valuable data on them.
Valued Contributor

Re: StorageWorks 1/8 G2 LTO4 "SEEK"

You posted a reply to a topic that is 3 years old.  You will probably get the best response if you create a new question and provide details about what exactly you are seeing.