StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Trying to use C7200 DLT library in SAN environment

SOLVED
Go to solution
Fedon Kadifeli
Super Advisor

Trying to use C7200 DLT library in SAN environment

We recently converted our SCSI DLT-8000 library to an FC library, connected to SAN and trying to get HP DataProtector backups of some Windows servers. Hardware configuration is as follows:

FYSRV: Win NT 4.0 SP6 servers running DP media and disk agents with 2 x QLogic QLA23xx PCI FC Adapters (one is used solely for disk I/O, the other is used solely for tape I/O).

SAN Switches: 2 x 2109-F16 IBM SAN Switch Model F16. These are actually Brocade switches.

DLT library: HP SureStore C7200-A5587A 60 slot, 4-drive library with 2 Fibre Channel cards.

Connection is as follows:

FYSRV + IBM (Qlogic) FC-133 HBAs
->
FC connections
->
2109-F19 IBM (Brocade) SAN Switches
->
FC connections
->
HP SureStore C7200 DLT Library.

DataProtector version is 5.00 and Cell Manager runs on HP-UX 11.00 box.

For backups that span multiple tape cartridges we CONSISTENTLY (I tried with different NT servers, different FC HBAs, different FC paths, different tape drives and cartridges) get the following errors:

....
<<< backup starts >>>
....
<<< first cartridge is filled up >>>
....

[Normal] From: BMA@fysrv "FYSRV-DLT3" Time: 24/07/2004 04:59:57 PM
Unloading medium to slot 18 from device scsi3:0:1:0C

[Normal] From: BMA@fysrv "FYSRV-DLT3" Time: 24/07/2004 05:00:40 PM
Loading medium from slot 17 to device scsi3:0:1:0C

[Major] From: BMA@fysrv "FYSRV-DLT3" Time: 24/07/2004 05:03:23 PM
[90:180] Cannot rewind medium. (Details unknown.)

[Critical] From: VBDA@fysrv "N:" Time: 24/07/2004 05:03:23 PM
Received ABORT request from SM => aborting.

[Critical] From: VBDA@fysrv "N:" Time: 24/07/2004 05:03:23 PM
Connection to Media Agent broken => aborting.

The problem (I think) is not in DataProtector, but in the FC connectivity. Presumably some SAN misconfiguration, because this problem does NOT occur when I connect the library's FC interface point-to-point to the NT server's FC interface.

I have noticed the following. The DLT library has 4 drives and 2 FC cards:

Fibre Channel Card Information
Fibre Channel Card Slot 1
Card Type: Fibre Controller - HVDS
Hardware Revision: 529
World Wide Port Name: 5006 0b01 0006 0db1
World Wide Node Name: 5006 0b00 0006 0db1
...
Addressing Mode: Hard
ALPA: 01


Fibre Channel Card Slot 2
Card Type: Fibre Controller - HVDS
Hardware Revision: 529
World Wide Port Name: 5006 0b01 0006 0ed5
World Wide Node Name: 5006 0b00 0006 0ed5
...
Addressing Mode: Hard
ALPA: 01

As you see both cards have ALPA: 01.

Switch zone is as follows: Server Port, DLTLib FC card 1, DLTLib FC card 2.

Do we need to set different ALPAs for the DLT library's FC interfaces?
5 REPLIES
Uwe Zessin
Honored Contributor

Re: Trying to use C7200 DLT library in SAN environment

It is not necessary when they are on different loops.

(Please try to stay within one thread - it doesn't make sense to post everything all over again)
For reference, here is the old one:
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=645441
.
Fedon Kadifeli
Super Advisor

Re: Trying to use C7200 DLT library in SAN environment

I switched from thread to thread for a reason:

Inititally I thought it was an DataProtector problem, then it turned out that the problem depends on FC connectivity, and now I am concentrated on the configuration of the DLT library itself...
Marino Meloni_1
Honored Contributor

Re: Trying to use C7200 DLT library in SAN environment

I'm not sure this could refer to a SAN connectivity problem, anyway, usualy I see the FCbridge of these libraries set as SOFT mode and not Hard with AL_PA when connected to a switch, because they can log on as N_Port.

You can have a check at the logs of the switch and see if you have some kind of errors of disconnections on the ports connected to the unit.

If the problem always occur when you load the second tape and then the drive cannot perform a rewind, or it is a config problem in Dataprotector, of the command Rewind cannot be performed for some reason.

I would aslo suggest to create a Sticket with LTT and to post it here

Marino
Marino Meloni_1
Honored Contributor
Solution

Re: Trying to use C7200 DLT library in SAN environment

I think that if you use a the lib in a SAN, you should set the FC card as "Soft" mode adressing

------
Switch / Fabric Attached Required Settings In the case of a device attached via a fibre channel switch it is required that the addressing mode utilize is SOFT. This setting can be performed via the RMC interface
Please note that utilizing Hard addressing when attached to a fibre channel switch is an UNSUPPORTED configuration, libraries attached to a switch must be configured as â Soft Addressingâ
---------

Also I would suggest to ugrade the firmware even if you have the last version reported by the library, because if I understand well, you added the FC Bridge at a second time, and as the Fibrary have severals FW, and each component if they are exchanged do not auto upgrade ;-)) if you have changed or added some component, it may be out of date, and with the FC card, the last FW version solved a lot of problems. (F.30 in on mine)

Fedon Kadifeli
Super Advisor

Re: Trying to use C7200 DLT library in SAN environment

I think Soft Addressing will solve the problem. I am still testing (with some promising results).

Thank you for your replies!