StoreEver Tape Storage
Showing results for 
Search instead for 
Did you mean: 

Unable to see TL891 library from W2K host

Ayman Altounji
Valued Contributor

Unable to see TL891 library from W2K host


I am having a problem where a W2K host is unable to see a TL891 minilibrary that is attached via a MDR. The MDR recognises the two 35/70 tape drives and what i am guessing is the robot (displays these when issued command ShowSCSIDevices).

The host in question recognises the MDR.

This has all worked previously, although we did recently move the SAN infrastructure and other equipment to another building, but all other aspects of SAN operations are fine.

All the cabling on the expansion and base units have been done correctly (as per how they were done before when it worked). All cables/terminator are properly attached to the devices.

Software is Arcserve2000. Still i cannot see the library using the TSMAC (i think that is what it is called) tape drive utility software that is provided by compaq.

If anyone has any ideas, please let me know.

Ayman Altounji
Valued Contributor

Re: Unable to see TL891 library from W2K host

Could you describe your SAN config in detail?
If you've connected an MDR and tape library to a SAN, you're probably using zoning or Selective Storage Presentation (or both) on the MDR to limit access to specified host(s).
What does "showhosts" tell you on the MDR?
Are you using an open or closed map?
Since the host can see the MDR itself one can assume that zoning and cabling is OK. That leaves the host map. Have you deleted the default map and specificaly assigned a host map to the host? Are there multiple hosts connecting to the MDR?
Does the MDR have one or two fabric ports?
Feel free to mail me and I'll see what I can do.

Re: Unable to see TL891 library from W2K host

hi , I have same problem and it takes long time with me, even I thought to give it up.

I have this TL891 minilibrary with one drive , also there is MDR with one fiber port and two SCSI port.

the library is connected to the MDR through SCSI cable. and the MDR is connected to fiber switch to which my w2k HOST is connected.

I can't see library on my host, and also through my backup software Arcserver.

I have found those stuff connected .

When I used serial cable and connect to MDR ican see the SCSI devices connected to it.
(Show SCSIDevices).

I'm new to this hradware.

Can some please give me full guide and idea how to setup this system.


Claudio Ruzza_1
Valued Contributor

Re: Unable to see TL891 library from W2K host

there are a couple of useful commands that should be issued by MDR's command line.
The first one is:
this commands gives as output the map with the association of SCSI BUS/Tgt/Lun to FC LUN. The default for MDR is an "dynamic Map", in other terms this command must give a table with as many entries as the numer of SCSI ID's of your tape library (one for the robotics and one/two for the drive/s).
If the command showfcscsimap doesn't give such an output it means that the MDR is set up with "static map". In this case, some Host's WWNames should have been previously associated with an alias, and a static map has been created for every alias. In order to know if any aliases has been created, please issue this command: getAlias
If at least any alias exist, re-run showfcscsimap . This shoul give a meningful output.
Another useful command is ShowHosts.
This command gives information about the connected Hosts recognized by its WWN. Discard the first, that is the MDR itself, and from the second to the last you can see the hosts as the MDR is able to see thru the SAN infrastructure. Double check the WWN as seen in the output of this command with the WWN that you can see in your Host's FC adapter utility software, and you can see if your host is seen by the mdr or not.
Finally, check if in your SAN environment zoning has been implemented/changed.

Hope it helps

Re: Unable to see TL891 library from W2K host

Hi Friend,

Thnaks very much for your welling to help.

I have try all you mention but I still have some doubts:

1- Do I need to set manuly the alias and wwwns, did they need be same, and should I use my host name ? as wwwn?

I'm thinking to forget a bout the MDR and connect the libraray direct to my server, but the port on my server is different than that on MDR which libraray is connected to, but I have other SCSI cable that can be pluged to my server scsi port, and after I have test this also I can;t see the libraray on my server, and also by my backup software.
I'm still in looping status.

Please advise.

Appreciate your help.
Claudio Ruzza_1
Valued Contributor

Re: Unable to see TL891 library from W2K host

please consider keeping your MDR.

Yes, you have to set up manually your aliases.

Firstly, check if your MDr sees SCSI peripherals. Run:


your output could be something like this:
Device# SCSI Bus# SCSI Target ID SCSI LUN Port# Slot# Type

0 0 0 0 0 0 0x0C

1 9 0 0 9 3 0x08

2 9 1 0 9 3 0x01

3 9 2 0 9 3 0x01

4 10 3 0 10 3 0x01

5 10 4 0 10 3 0x01
Sorry for misalignment. Run it on your MDr and you'll see better.

Check if you see your peripherals. Remember that Type 0x0C stand for MDR itself, 0x08 stand for Changers and 0x01 stand for tape drives.
If you can't see you robotcs probably your problems is on cabling or robotics controller. Fix it and retry MDR mapping.

If you can see everything, proceed with mapping, starting with an alias creation.
You have to complete your command following this syntax:


You will get the WWN of your server double checking it within your operating system (for instance, if you have a HP FC ctrl you can run the lputilnt tool) and asking the mdr if this host is seen with showhosts.
the output of showhosts looks like this:

Port Number : 1

World Wide Name -

Node Name : 50:05:08:B3:00:40:71:38

Port Name : 50:05:08:B3:00:40:71:39

Source ID : 0x021C00

Status : Enabled

Operation Mode : Fibre Channel Target

Host World Wide Name -

Host Node Name : 20:00:00:00:C9:22:36:89

Host Port Name : 10:00:00:00:C9:22:36:89

AliasName :

Is Currently Logged In : Yes

Source ID = 0x021800

Operation Mode = Fibre Channel Initiator
in this example there is as a first host the MDR itself. The second host is a real server.
If you want to set an alias of your host run "setalias" using as host WWN the "Host Port Name". In our example: 10:00:00:00:C9:22:36:89

After having set an host alias, you should associate a SCSI-TO-FC map to your newly created alias. Run this:

AMC>createmap 1

where 1 is the FC port map number of your MDR.

latest two steps:

The default map is to be cleared. Are you sure? (Y/N) y

Map Entries in the default map are deleted.


AMC>setMapUpdateModel closed

The Default Map Update model is set to CLOSED model.
Please remeber that this procedure will create a STATIC map (=more stable and reliable) for your server. This means that if you will add a new server in your SAN, this new server will NOT see the library. You have to reproduce this procedure for the new server if you want to allow it to see the library.

Reboot the mdr and discover your hardware within Win2k Device manager.
Do not install any tape or robotic driver because arcserve will complain for this.
That's all. Hope it's clear.

Let us know



Re: Unable to see TL891 library from W2K host

Thnaks Claudio ,

I'm about to overcome this with your support.

My status now is like this, after I have followed your instructions:

1- In my w2k device manager I can see Compaq SCSI Array data Router, but it's marked with yellow color as it's suffering for diver!

In my Arcserver backup software I can see the only tape drive look like 3@ ! no library is observered, and I can't can configure my decive using device configurartion wizared with in my backup software, it tells that there is no autchanger assigned.

Would please extened your Help ?

Many Thanks.
Claudio Ruzza_1
Valued Contributor

Re: Unable to see TL891 library from W2K host

I apologize!
I forgot this:
-run AMC>setmapupdatemodel open
-delete all static map
-run the command AMC>setsccmode off
You will be warned the your default map will be recreated. Answer yes
-reapply all the suggestion I gave in my previous post
-reboot MDR
-delete the yellow question mark in win2k
-scan for hardware changes in your win2k server

that's all


P.S. if you run amc>showscsidevices you see everything?
Satish Kumar_5
Regular Advisor

Re: Unable to see TL891 library from W2K host

I have a similar kind of setup.after following ur instructions, i was able to see my robot and drive(1 drive) in windows 2k but when i configure in arcserver 2000, while doing autoconfig,it gives msg no tape in changer. i tried so many things but still this msg keeps.sometimes i get unable to initialise changer.any help will be really appreciated.

Thanks in Advance