StoreEver Tape Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

VMware ESXi 5.5 sees tape drive but not autoloader

SOLVED
Go to solution
dwm_1
Occasional Contributor

VMware ESXi 5.5 sees tape drive but not autoloader

I have a HP StoreEver 1/8 G2 LTO-4 Ultrium 1760 SAS Tape Autoloader connected to a HP Smart Array p421 controller inside an HP DL380p server.   VMware ESXi 5.5 is installed on the server.   The ESXi host can see the p421 controller and the Tape Drive attached but is unable to see the AutoLoader.

I installed a Windows 2008 R2 server with Symantec Backup Exec 2012 and it only sees the tape drive.

 

Researching the problem I came across an HP knowledge base that states that the Tape autoloader uses a single SCSI id and two logical units to control the tape drive and autoloader.   The HP Smart Array Controller must be able to provide multiple LUNs.   When I bought these products HP said that the p421 controller works with the Tape Autoloader.

 

What do I have to do to get the VMWare host to recognize both the tape drive and autoloader?

8 REPLIES
Torsten.
Acclaimed Contributor
Solution

Re: VMware ESXi 5.5 sees tape drive but not autoloader

Check the link from the quickspec

http://h18000.www1.hp.com/products/quickspecs/productbulletin.html#spectype=worldwide&type=html&docid=12630

SAS Host Bus Adapters The 1/8 G2 Tape Autoloader is certified with a number of HP SAS Host Bus Adapters. For the most current list of supported SAS HBAs, please see the HP Storage EBS (Enterprise Backup Solutions) Compatibility Matrices document and EBS Design Guide located at: www.hp.com/go/ebs.

For more information on SAS HBAs, please see Fibre Channel Host Bus Adapters at: http://h18006.www1.hp.com/storage/saninfrastructure/hba.html.


The recommended controller is this:

HP SC44Ge SAS Host Bus Adapter
NOTE: Recommended for Proliant G5 SAS tape automation connect.
416096-B21

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
dwm_1
Occasional Contributor

Re: VMware ESXi 5.5 sees tape drive but not autoloader

OK thanks,   HP reps. recommended this part, so I guess they sold me the wrong thing.

Torsten.
Acclaimed Contributor

Re: VMware ESXi 5.5 sees tape drive but not autoloader

According to your controller specs

http://h18006.www1.hp.com/products/quickspecs/productbulletin.html#spectype=worldwide&type=html&docid=14229

the combination is supported.

Maybe a vmware limitation?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Miguel_Leal_PT
Occasional Visitor

Re: VMware ESXi 5.5 sees tape drive but not autoloader

There is one solution, i just put it to work.

This took me 1 week of testing, and it works great.

 

jmarcano
Occasional Visitor

Re: VMware ESXi 5.5 sees tape drive but not autoloader

Please share how you resolved this issue.  I am running into the exact same problem.

 

Thanks

Shahzad_Khan
Occasional Visitor

Re: VMware ESXi 5.5 sees tape drive but not autoloader

Please Share how you solve this problem. i have almost same problem...

 

i Connect my HP Auto Loader with my power edge R720 Server, My windows server 2008 R2 detect the Tape and and even my Symantec backup 2014 and 2012 detect but give me error no Media ... please share your knowledge with us. thanks.

TODD SMITH
Visitor

Re: VMware ESXi 5.5 sees tape drive but not autoloader

Hello

 

How did you get the autoloader to work with ESX server?

Just got a new autoloader and card trying to configured it.

Re: VMware ESXi 5.5 sees tape drive but not autoloader

Hello,

for my knowledge there are two ways: PCI Passtrough or ESXi- HBA- driver. But PCI Passtrough is broken since 5.5 for some Proliant´s and HBA´s.

In the past I where successful with the following, maybe this is also a way for newer adapters:

old LSI1068e, mptsas

esxcfg-scsidevs -a
esxcli storage nmp satp rule add --satp VMW_SATP_LOCAL --driver="mptsas" --description="Rule for local path of LSI-Controllers"

LSI SAS2308 H222, mpt2sas

esxcfg-rescan vmhba2
grep "ScsiScan" /var/log/vmkernel.log
vmhba2  mpt2sas           link-n/a  sas.500605b005xxxx                    (0:7:0.0) LSI Logic / Symbios Logic HP H221 Host Bus Adapter

esxcli storage nmp satp rule add --satp VMW_SATP_LOCAL --driver="mpt2sas" --description="Rule for local path of LSI-Controllers"

2014-05-04T08:52:06.545Z cpu5:8772)ScsiScan: 1373: Add path: vmhba1:C0:T0:L1
2014-05-04T08:52:08.964Z cpu2:8774)ScsiScan: 888: Path 'vmhba2:C0:T0:L0': Vendor: 'HP      '  Model: 'Ultrium 4-SCSI  '  Rev: 'U61W'
2014-05-04T08:52:08.964Z cpu2:8774)ScsiScan: 891: Path 'vmhba2:C0:T0:L0': Type: 0x1, ANSI rev: 5, TPGS: 1 (implicit only)
2014-05-04T08:52:08.969Z cpu4:8774)ScsiScan: 1373: Add path: vmhba2:C0:T0:L0
2014-05-04T08:52:08.969Z cpu13:8378)ScsiScan: 888: Path 'vmhba2:C0:T0:L1': Vendor: 'HP      '  Model: '1x8 G2 AUTOLDR  '  Rev: '4.20'
2014-05-04T08:52:08.970Z cpu13:8378)ScsiScan: 891: Path 'vmhba2:C0:T0:L1': Type: 0x8, ANSI rev: 5, TPGS: 1 (implicit only)
2014-05-04T08:52:08.973Z cpu13:8378)ScsiScan: 1373: Add path: vmhba2:C0:T0:L1

After that you can simply add changer and tape drive to one VM.

Hope that helps a little bit.

Mathias