cancel
Showing results for 
Search instead for 
Did you mean: 

llt on hp10/180

Ross Anderson_1
Occasional Contributor

llt on hp10/180

I've been struggling with the configuration of the ltt utility on Gentoo (linux vanilla source 2.4.26) w/ dev file system.

I'm able to address the device using mtx at /dev/sg1 which is how gentoo has defined the device.
The 4 dlt 7000 devices are also available at /dev/st0 - /dev/st3. for mt tools.

My backup software is also able address the tape devices and library.

When I start the llt utility is does not find any devices. When auto detection is used it fails with the following output.
OC_Exception_c caught: Internal error (oc_devicemap_linux.cpp, 534, Unable to find the sg device file)


I tried suggestions posted here. I followed the instructions under the help files.

I also tried the suggestion one gentlemen made about creating device files

mknod /dev/sga c 21 0
mknod /dev/sgb c 21 1
mknod /dev/sgc c 21 2

Currently I have 4 devices /dev/sg0-sg4 since I have 4 scsi cards in a dell 2450. The hp library resides on the 2nd scsi card and the tape drives are divided between the 3rd and 4th cards.

Gentoo creates the links to the appropreate generic mount points.

Any thoughts/comments as to how I can get this utility to work??? I'm very much at a loss.

Thanks
1 REPLY
Ross Anderson_1
Occasional Contributor

Re: llt on hp10/180

As an adendum. By doing

mknod /dev/sga c 21 1

and doing a manual hardware scan, entering the /dev/sga address it does find the libary but I can't get the drives to pull up at all.

Hardware scan does not work yet.

I'm also only able to manually enter one address so the tape drives appear offline.

I have taking this same machine, created another partition, loaded windows xp, and setup the hp software and that works fine. It seems a bit silly to to that when it is some configuration I'm missing. Thanks for any help. I know I'm just missing the obvious.