StoreOnce Backup Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

D2D2504i doesn't boot after firmware upgrade

Stijn Derison
Occasional Visitor

D2D2504i doesn't boot after firmware upgrade

Hello,

I was trying to update the D2D firmware. When he was in the progress of doing the upgrade, the webinterface gave me an error messagebox saying the upgrade has failed.

I tried to upload the .E file again via the webinterface. This time it gave me the same error immediately.

Everything in the webinterface still worked, so I thought that there was no harm done. I told the D2D to reboot itself (so I could try again).

The D2D never came back online. I went to the D2D to look at the console. It tries to load the linux kernel, but seams to be stuck somewhere (see attachment).


Could somebody please help me. The D2D needs to be online very urgent. It is possible for me to go back to factory defaults. I have a copy of my backups.

Is there any way to reinstall the OS?


Thanks,
Stijn Derison
4 REPLIES
Dave Dewar
Trusted Contributor

Re: D2D2504i doesn't boot after firmware upgrade

The OS is embedded on a USB Flash Stick, therefore you cannot simply reinstall the OS.

It looks like the USB Flash stick is at fault for your 2504. You will need a new USB Flash Stick, available as a spares part from HP - Part Number = 581909-002. When received, shutdown the D2D, open the lid, swap out the USB Flash stick (which is located between the disks and fans). Details are shown on a hood lable on the inside of the lid.

You will not lose any of your data on your D2D as a result of this replacement of USB Flash Stick, although depending upon the original firmware revision and the amount of data you have stored on your D2D, please be patient on initial power on - it may take a couple of hours to come back online while it goes thru checks.
Stijn Derison
Occasional Visitor

Re: D2D2504i doesn't boot after firmware upgrade

Hi,

Thanks for your reply, but I resolved the issue myself.

HP support told me that there is no way to fix the problem and that the USB stick has to be replaced.

So I tried to fix the problem myself and it worked. I looked at the bootloader and I saw that there is a choice to load an old kernel.

You have to press F1 or F2 before the native flash starts to load. Then you get a boot menu where you can choose to load the old kernel.


thomasr
Respected Contributor

Re: D2D2504i doesn't boot after firmware upgrade

I've also had luck in performing a hard power off after a firmware upgrade. Wait until the system starts to boot and fails, then turn the power off. Upon boot, it seems to come up fine with the new FW (at least on the 2503i units I had).
--
Liberty breeds responsibility; Government breeds dependence
Stijn Derison
Occasional Visitor

Re: D2D2504i doesn't boot after firmware upgrade

I tried the hard power off. I didn't make any difference.

I always look at the webinterface when I do a firmware upgrade (in case something goes wrong).

The firmware failed right after he said that the boot partition was changed.

At HP customer support they had never heard from the recovery mode wich is build into the system. They were very thankful :-)