StoreVirtual Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

2 Node Cluster with FOM, upon maintenance the cluster goes offline

jlevicke
Occasional Visitor

2 Node Cluster with FOM, upon maintenance the cluster goes offline

We were updating the ESX host and put the host in Maint mode which migrated all the VM's to the other host. We powered off the VSA for that host and the storage cluster became inactive on both hosts. It seems that the FOM didnt failover the cluster but it looked online in the console. Has anyone experienced this, we have done this in the past wihout issue.

3 REPLIES
oikjn
Honored Contributor

Re: 2 Node Cluster with FOM, upon maintenance the cluster goes offline

what did it say in CMC?  was there a quorum problem or did CMC think everything was ok?  If CMC thought all was OK, then its likely a setup problem with your initiators and you need to check those settings.

jlevicke
Occasional Visitor

Re: 2 Node Cluster with FOM, upon maintenance the cluster goes offline

CMC looks ok, no errors but as soon as I put the ESX host in Maint mode, migrate the VM's and shutdown the VSA for that host the storage cluster changes to inactive. I didnt check the CMC after it happened I just powered the Host backup and the VSA and everything came back. Where do you check the initiators?

oikjn
Honored Contributor

Re: 2 Node Cluster with FOM, upon maintenance the cluster goes offline

initiators are the clients connecting to the SAN.  In this case its the ESX hosts.  If they lose their connection when you shut off a single node, then its likely that you don't have MPIO setup correctly.  Follow the HP guide for setting up with ESX and it should work.

 

If you can repeat this in a controlled condition, it would be helpful to know if CMC has a problem or if its just ESX that is having the problem.  If you can shut down all the VMs and then shut off one host and then try and connect to CMC, you should be able to connect and it will only give you a warning that one node is offline.  If there is a problem with the SAN, you might not be able to connect to it with CMC or it will connect and throw alarms about LUNs being offline.  If CMC isn't already complaining about quorum or connection problems with the FOM or either node then I would bet the problem is the ESX host iscsi config.

 

 

Side question... WHERE is your FOM located?