StoreVirtual Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot turn on Jumbo frames or Set Flow Control in CMC

FPMG
Occasional Visitor

Cannot turn on Jumbo frames or Set Flow Control in CMC

Good afternoon,

 

I am having a problem turnning on Flow control and Jumbo frames in the CMC for my HP4330 and HP4300 Sans. It gives me "An unknown error occured" Running Version 12 of SanIQ

 

Any ideas on where to look?

9 REPLIES
oikjn
Honored Contributor

Re: Cannot turn on Jumbo frames or Set Flow Control in CMC

Contact support on that one.  It should be functioninal, but I"m using the VSAs and some time around v11 jumbo frames stopped working and for me it wasn't critical to get back on so I just moved back to standard frame sizes. 

 

That being said, the hardware units are supposed to support everthing you said so if it isn't, contact them to see why not.  Maybe you found a bug.

Bart_Heungens
Honored Contributor

Re: Cannot turn on Jumbo frames or Set Flow Control in CMC

Are you trying to do this on the bond?

 

If I remember well (I am using also VSA, it is quite some time ago when I installed the physical appliances) you have to set flowcontrol and jumbo frames on NIC level and not on bond level...

 

So I expect that you have to break the bond, enable FC and JF and recreate the bond...

--------------------------------------------------------------------------------
If my post was useful, clik on my KUDOS! "White Star" !
My blog: http://blog.bitcon.be
vlho
Advisor

Re: Cannot turn on Jumbo frames or Set Flow Control in CMC

Hi FPMG,

 

install patch 50010

It fixes:

When modifying flow-control settings for a bond, it will now complete successfully. Previously, modifying the settings failed with the message, "The flow control was not set. An unknown error occurred

Princes
Advisor

Re: Cannot turn on Jumbo frames or Set Flow Control in CMC

I cannot turn on either Flow Control or MTU9000 (Jumbo Frames) either within the CMC v12.5 Console for a 2 x VSA v12.5 Node Cluster (options simply greyed out in either VSA network interface). I have also tried to set the MTU to 9000 on the VSA iSCSI interface via the VSA Console, however this now gives me the message: "FAILED: The specified frame size is invalid for this device".

Normally I'd think that I'd simply configured the networking incorrectly somewhere in the design, however Jumbo Frames worked fine in v11.5, from which this set-up was upgraded to v12.5. Now it no longer appears to be an option or is in some way disabled for this build. Is anyone else able to set this facility in VSA v12.5?

Princes
Advisor

Re: Cannot turn on Jumbo frames or Set Flow Control in CMC

Update: Bizzarely, I have enabled 9000MTU (Jumbo Frames) on all the associated ESXi host vmk iSCSI interfaces, Software iSCSI Adapters, upstream Switches etc. and the v12.5 VSA's seem to be able to operate normally even without being able to set 9000MTU on them. On v11.5, doing this without setting 9000MTU on the VSA's would cut them off the network (as expected). It almost seems as if the VSA v12.5 is able to detect this - I can ping each VSA using 9000MTU size as well! Testing performance, I see a corresponding improvement in performance consistent with enabling 9000MTU even though it remains unconfigured on the VSA!

oikjn
Honored Contributor

Re: Cannot turn on Jumbo frames or Set Flow Control in CMC

that is how it used to operate back in v9 days as well.  It stopped doing that in v10 with no comment in the update notes.  nice to hear its back and you can use jumbo frames again.  I wish they would put this into the update notes!

Princes
Advisor

Re: Cannot turn on Jumbo frames or Set Flow Control in CMC

Right,

HP Support have now informed me that the reason that Jumbo Frames cannot be set in VSA v12.5 (and v12.0 apparently), is that the VMXNET3 adapter (which the VSA installer configures for both VSA interfaces by default), is no longer enabled for use with Jumbo Frames. In order to use Jumbo Frames, you must replace the adapter with the E1000 adapter type. I have tried this and discovered that I can now indeed set Jumbo Frames on this adapter, however I also noted that this adapters top speed is 1000Mbps. I am using a 10000Mbps network, which the VMXNET3 does support. This would appear then now to imply that Jumbo Frames is no longer an option with 10000Mbps networks (to be honest it makes little improvement enabling Jumbo Frames on a 1000Mbps network - the best improvement is typically seen on 10000Mbps networks).

Nothing in any of the VSA User, Configuration or Design Guides I can find that explains this.

Princes
Advisor

Re: Cannot turn on Jumbo frames or Set Flow Control in CMC

Right - finally heard back from HP and the official line seems to be that Jumbo Frames are not supported on any other Adapter than a manually added VMware E1000 Adapter (replacing the installed default VMXNET3 Adapter). However, the legacy E1000 is limited to 1Gbps Networking whilst the VMXNET3 extends to 10Gbps Networking and in a real world situation, Jumbo Frames only really make any difference on a 10Gbps Network (as is often pointed out in HP documents relating to the LeftHand platform).

So an important and useful feature that was working well in VSA v11.5 has been removed or disabled in VSA v12.5 (and probably v12.0). This is not the first time HP VSA design features that naturally become part of customer architecture appear to be removed in the next 'upgrade' build with little explanation or documentation to the effect. Such behaviour makes it very difficult for customers to design and plan platforms that make use of the VSA solution.

Princes
Advisor

Re: Cannot turn on Jumbo frames or Set Flow Control in CMC

Just noticed Jumbo Frames have been re-enabled now in recently released VSA v12.6 for 10GbE VMXNET3 Adapter.

Why remove important features like this. It makes planning host infrastructure a nightmare...