StoreVirtual Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Create New Cluster / Virtual IP Issues

SOLVED
Go to solution
KenJRay
Occasional Visitor

Create New Cluster / Virtual IP Issues

This has me stumped.  We've been using StoreVirtual / VSA software for several years, and currently have four VSA systems on some of our ESXi hosts, with two HP D2220sb storage blades, each with 12TB of storage.  This has been working pretty well.  We are now moving to a new project, upgrading one of our key business applications, and to support this, we bought another three BL-460c server blades, and another D2220sb and put them in our c7000 chassis.  ESXI 5.5 has been installed on all three server blades.  Each server blade has to 10Gbps pass-through network connections, one of them on our primary internal network (172.17.1.x), connected to a Cisco core switch, the second is on a separate network (172.20.1.x) connected to a HP switch, purely for iSCSI storage network traffic.

 

I set up three VSA instances on the server blade attached to the storage blade; all three storage systems have been added into the StoreVirtual CMC.  What I now want to do is create a new cluster for these three systems, I go through the wizard adding them to the current management group - but when I get to the step where it askes for a virtual IP for the cluster, it only gives me the option for the 172.17.x.x subnet - for some reason the 172.20.1.x subnet isn't visible.  But when I look at the network properties of each of the storage systems, it shows both networks, with the correct IP addresses that were configured in each VSA.

 

What's going wrong?  I'm running Version 11.0 of the CMC - I can't get updates, because there seems to be an issue with the proxy settings for the upgrade FTP process (but that has worked faultlessly until now.

 

Thanks in Advance

 

Ken Ray

Clay County Clerk of Courts

2 REPLIES
JazzyB
Occasional Advisor
Solution

Re: Create New Cluster / Virtual IP Issues

Did you bind the Lefthand OS/iSCSI interface to the correct NIC? There is a setting that can be changed under each storage device under Network, communication tab.

 

I ran into a similar issue a while back because i forgot my iSCSI traffic was set to run on eth1

 

KenJRay
Occasional Visitor

Re: Create New Cluster / Virtual IP Issues

That was the solution - fantastic.  I was a little worried when I went into Netowkr / Communication, and then from "Communicaiton Tasks" selected "Select LeftHand OS Interface, and made it eth1 (my iSCSI network), the VSA system went off line... but it came back soon enough.