StoreVirtual Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Exchange not available during snapshots of data volume?

SOLVED
Go to solution
Rascii
Occasional Advisor

Exchange not available during snapshots of data volume?

I have a scheduled snapshot of our Exchange database volume using App Aware version 12.0.0.507 with vCenter 6 on the HP Storevirtual 4330. At the snapshot time I can see vCenter doing the snapshot and Outlook cannot connect to Exchange during this time. Is this normal? The disconnect is for about 10 - 20 minutes every night.

7 REPLIES
oikjn
Honored Contributor

Re: Exchange not available during snapshots of data volume?

not normal.  what version storevirtual are you using?  What version for the app snapshot program?  Have you tested the program to make sure the credentials work?  Sounds like you either didn't configure the snapshot app with the correct credos are not correct. 

Rascii
Occasional Advisor

Re: Exchange not available during snapshots of data volume?

The CMC is the latest 2.6.00 Build 0155.0. The App-Man Snapshot is 12..0.0.507 and is the latest as mentioned above and is installed on our 2012 R2 vCenter server. The HP node level is at version 12.0.00.0725.0 as I'm gun shy about upgrading to 12.5 or 12.6. When I upgraded to version 12 while running VMWare 6 we went through a nightmarise two weeks of data corruption of our 2013 Exchange server until HP released a patch. I restored mailboxes multiple times for two weeks until the fix was found and seperated our Exchange into two db's so that only half of our mailboxes would get corrupted when it happened.

As far as the Snapshot schedule, it doesn't appear to be editable once set and I believe it checks the credentials each time you click ok. I'm thinking if it couldn't connect or validate it would not allow me to save or click ok to the setting? Unless you think I should delete it all and create a new schedule?

Thanks

oikjn
Honored Contributor

Re: Exchange not available during snapshots of data volume?

on each server which has the app-manager program, you have to open the program and setup at least a default management group login credential.  I suggest you setup a specific one for the management group in question.  when you do that, there is a test or validate button there which will confirm that it works.

 

when you setup the schedule in CMC, I believe it only sets up the schedule task and doesn't check to make sure the app-aware program is installed and configured per server.  My guess is the credentials on the server aren't setup correctly and it is stalling out attempting to use the app-manager program and then defaults back to an unassisted method. 

Rascii
Occasional Advisor
Solution

Re: Exchange not available during snapshots of data volume?

I have the default management group setup on the server and the credentials test ok. From past experience when I needed to upgrade the App-Aware software I've learned that if it's not communicating or if the credentials are wrong when you go to check the box in the CMC snapshot schedule for Application-Managed Snapshot it does a communications check right then. It will come up with an error if you don't have the credentials setup.

I guess my next question would be since I'm not seeing any alerts\errors, where would the logs be or how do I troubleshoot this?

Rascii
Occasional Advisor

Re: Exchange not available during snapshots of data volume?

Ok, I just found two places for credentials. The first I checked was to right click the default and select Management Group properties. These seemed to be ok. The next set I found is clicking on VMware Integration Options on the left menu and when I ran a test these failed so I re-entered the same password for the first box and now the test is successful.

I hope this works, but I'm also dumbfounded as to why there is no type of indication at all that there was a problem. If I wouldn't have tried to use email very late at night and accidently found I had no connection I would have never dug into what the issue is.

So if the credentials fail then the snap reverts to a static method with no alarm or alert?

Are there some detailed logs somewhere?

Thanks

oikjn
Honored Contributor

Re: Exchange not available during snapshots of data volume?

all valid questions, but all beyond me.  I stopped understanding their logic shortly after HP bought lefthand networks  :-P

 

you should see logs in windows regarding VSS.  they are generally only informational level and not errors even if they actually are errors...  thats a M$ issue.  If you don't see any triggered VSS log then you should go to the technet forums and see about enabling and tracking down VSS issues.

Rascii
Occasional Advisor

Re: Exchange not available during snapshots of data volume?

Thanks for your help. You helped me track it down. I will test tonight as I can't run it now and risk 20 minutes of failed connections to Exchange.