StoreVirtual Storage
Showing results for 
Search instead for 
Did you mean: 

LeftHand snapshot unable to be mounted as a drive on a Windows 2008R2 server

Andrew Kaplan
Super Advisor

LeftHand snapshot unable to be mounted as a drive on a Windows 2008R2 server

Hello --


We are running two LeftHand P4000 clusters where snapshots are copied from the primary cluster, SAN1, to the secondary. The snapshot in the secondary, SAN2, is in turn, made available via an iSCSI mount on a Windows 2008R2 64-bit server. We have a system in place that has been proven to work in the past, and it is outlined below.


To make the snapshot on SAN2 available to the server, the administrator goes to the secondary cluster via the Centralized Management Console, selects the snapshot in question, right clicks on it, and selects the Assign and Unassign Servers option, and then selects the target server.


Once that is done, the administrator then goes to the target server, logs in with a domain user account that has local administrator access, and then selects the iSCSI utility. The refresh button is used, and the snapshot is shown to be available. The snapshot is selected, and a connection to the server is shown to exist. Normally once that is done, a drive letter is assigned to the snapshot, and its contents are available.


The problem is the following: Even though a connection is shown, the snapshot is not getting mounted or assigned a drive letter, and is therefore not readily accessible. The Disk Management utility on the Windows server does show a drive number, but nothing beyond that.


We have tried disconnecting from the Window server as well as rebooting it. Additionally we have gone to the LeftHand and unassigned and reassigned the snapshot. None of these steps have been successful in getting the snapshot to appear as a drive and be accessible.


What would cause the snapshot to suddenly not be available, even though the above procedure has worked previously?



P.S. This thread has been moved from Disk Array to HP StoreVirtual / HP LeftHand Storage - HP forums moderator



A Journey In The Quest Of Knowledge
Honored Contributor

Re: LeftHand snapshot unable to be mounted as a drive on a Windows 2008R2 server

have you tried actually mounting and assigning a letter in windows disk management?


was this the same "drive" you have been mounting in the past on the same server or is this a different drive?  If its different, that could explain why the drive didn't automatically get assigned a drive letter.