StoreVirtual Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Losing LH quorum after adding additional two new switches to network

SOLVED
Go to solution
luumanio
Occasional Contributor

Losing LH quorum after adding additional two new switches to network

Hi,

 

I think I finaly need some help re my LefHand/Network configuration:) At the moment I have the following infrastructure:

3 LH nodes (LH1, LH2, LH3) and two Cisco 3560 switches (switch1, switch2). Each node is connected to switch1 and switch2 for redundancy purpose of course. Each switch port (connected to LH) has the following configuration. 

 

description iSCSI SAN Uplink
switchport access vlan 98
switchport mode access
flowcontrol receive desired
spanning-tree portfast

 

So I have three ports configured as above for NIC1 for each LH and the second switch has the same switch port config for NIC2 for each LH. I also have Port channel for  iSCSI trunk configured between switches as follow.

 

interface Port-channel1
description iSCSI Trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 98
switchport mode trunk

 

interface GigabitEthernet0/5
description iSCSI Trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 98
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/6
description iSCSI Trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 98
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
!

 

Everything works perfect in the above configuration but I now received two new switches and new  SAN and my idea is to move all iSCSI traffic with 0 downtime to new switches swtich3 and switch4, and separate it from the rest of the network. 

 

New switches are configured exactly same way when it comes to switch ports for LH connection and between switches I again have port channel, and configuration works no problem. 

Problems start when I connect switch1 to switch3 and switch2 to switch4 using trunk port for iSCSI communication in my case vlan 98. As soon as I plug the network cables for the trunk between new and old switches I lose Quorum on one of the LeftHands in my case LH3. I've checked everything, physical connections, switch configuration but still can't figure out why I lose quorum. 

 

Any idea what might be causing such a behaviour and why I lose quorum where as you can see all network connections are fully redundant and I shouldn't lose quorum.

 

 

Regards,

Luu

2 REPLIES
fqu
Visitor
Solution

Re: Losing LH quorum after adding additional two new switches to network

I think it's because you're making a loop between all switches, and you get a broadcast storm.

luumanio
Occasional Contributor

Re: Losing LH quorum after adding additional two new switches to network

I didn't think properly, as usual human error:) I removed one connection and all worked!