StoreVirtual Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

MPIO not delivering increased throughput?!

SOLVED
Go to solution
BulkRate
Occasional Advisor

MPIO not delivering increased throughput?!

I have a consolidated backup of several remote office storage VSAs that perform nightly remote copies to a local cluster of two VSAs serving storage up from a pair of DAS drives in a couple of physical servers.  I've also got a local guest that mounts and backs up current copies of these volumes to tape.  The volumes on the VSAs are network RAID10, the physical disks are RAID0 (they;re just there for scratch space, and node-level fault tolerance is OK for this application).  Running SanIQ v9.5.

 

I notice that throughput seems limited to about 20-30 MB/s, considering that there's two nodes to read from and they each have a 1gbps connection on different physical hosts.  It's stable, but appears to only be using one NIC on the backup guest when accessing the volumes on the central VSA cluster.  I do get three connections automaticaly made to the VIP whenever I connect to a snapshot, so it LOOKS like the DSM's doing its thing, but not...quite. 

 

All three connections are made from the same, single initiator IP instead of balanced between the two available NICs...I can use either to make the initial connection if I drill down to the Advanced level of the connection dialog box in 2008R2.  But I can't seem to get both to work together and get the increased throughput that I was expecting.

 

Suggestions?  Or have I completely missed the point and It Doesn't Work Like That?

2 REPLIES
BulkRate
Occasional Advisor

Re: MPIO not delivering increased throughput?!

The sound of crickets chirping is deafening.  ;-)

 

Paul...you've got this set up for your Exchange 2010 infrastructure, right (guest-based VM initiator to a two-node P4500G2/G3 cluster)?  If yes, do you see i/o/throughput inline with aggregation over two links, or are you limited to that of a single NIC?

 

Or are you on a 10GbE solution, making my mpio question irrelevant?

BulkRate
Occasional Advisor
Solution

Re: MPIO not delivering increased throughput?!

Never mind...I wasn't following ALL the directions.  Namely the "repeat connection dialog for your other NIC" part. 

 

Kinda important.